Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26733 Discussions

Internal compiler error C0000005 in a project making calls to MKL

jirina
Novice
124 Views

I am getting an internal compiler error C0000005 when compiling a project that makes a call to the MKL routine Pardiso. I created a small reproducer, it is attached to this post. I am trying this in Parallel Studio XE 2017 Composer Edition Update 2 in Visual Studio 2015 Community.

The very same example compiles well in Parallel Studio XE 2016 Composer Edition Update 4 in Visual Studio 2010 Professional SP1, but it crashed when it is run; I am trying to resolve this problem in the MKL forum here.

My OS is Windows 7 Professional SP1 64-bit, with all updates installed.

0 Kudos
1 Solution
Kevin_D_Intel
Employee
124 Views

Thank you jirina. This is another instance of using /debug-parameters:all with /debug with PSXE 2017 Update 2 initially reported here.

You can temporarily avoid the internal compiler error by removing /debug-parameters:all (under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None)

View solution in original post

3 Replies
mecej4
Black Belt
124 Views

I installed Parallel Studio 2017-Update 2 today. When I ran the compiler on your source files with /extend_source, I did not see any ICE.

The other error that you described -- an illegal access error inside MKL -- in https://software.intel.com/en-us/forums/intel-math-kernel-library/topic/714891​ -- is traceable to an incorrect type declaration for the argument PT to Pardiso. I have responded on how you can fix this issue in that thread.

Kevin_D_Intel
Employee
125 Views

Thank you jirina. This is another instance of using /debug-parameters:all with /debug with PSXE 2017 Update 2 initially reported here.

You can temporarily avoid the internal compiler error by removing /debug-parameters:all (under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None)

View solution in original post

jirina
Novice
124 Views

Thank you very much; the suggested workaround works well and I am no more getting the internal compiler error.

Reply