Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Suppress warning 402

awa5114
Beginner
197 Views

forrtl: warning (402): In call to WRITEINTEGER an array temporary was created for blablablabla

I get a crapton of these warnings everytime I compile&run my program. I've seen some suggestions in https://groups.google.com/forum/#!topic/comp.lang.fortran/euk_DCVHK_M and https://stackoverflow.com/questions/27751905/warning-message-402-an-array-temporary-created-for-argument to use -check:noarg_temp_created to suppress the warning:

Ok, I am cool with suppressing the warning, but where do I place the check:noarg_temp_created if I'm using Visual Studio 2010?

0 Kudos
4 Replies
awa5114
Beginner
197 Views

Allright nevermind I got it. It needs to be placed in Project>Project Properties>Fortran>Command Line>Additional options as /check:noarg_temp_created. I got it from this link http://documentation.pflotran.org/user_guide/how_to/installation/windows_visual_studio.html

Steve_Lionel
Black Belt Retired Employee
197 Views

You apparently enabled this option under Run-Time, and now you're turning it off again through Command Line. Why not just turn it off under Run-Time? It isn't on by default.

awa5114
Beginner
197 Views

how do I turn it off under run-time ?

gib
New Contributor II
197 Views

Project Properties > Fortran > Run-time > Runtime Error Checking > Custom > Check For Actual Arguments Using Temporary Storage

Reply