Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
30 Views

Turn off automatic reallocation of arrays on compiler 19.0

The automatic reallocation of array feature is not turned on by default of compiler 16.0. Now I'm using 19.0 and the automatic reallocation is giving me trouble. How do I turn it off?

0 Kudos
7 Replies
Highlighted
Valued Contributor I
30 Views

-[no]standard-realloc-lhs
          explicitly sets assume keyword realloc_lhs to conform to the
          standard, or to override the default. Sets -assume [no]realloc_lhs

0 Kudos
Highlighted
Black Belt Retired Employee
30 Views

What kind of trouble is it causing? Having it enabled (thus conforming to the standard) should have no effect on a correct program.

0 Kudos
Highlighted
Beginner
30 Views

For compiler 16.0, when I allocate an array of size 1 and set it equal to an array of size larger than one, it will just grab the first element. Now in 19.0, it will tell me error saying array size don't match.

0 Kudos
Highlighted
Valued Contributor I
30 Views

So you should be glad that the more modern compiler is detecting your programming error.

0 Kudos
Highlighted
Beginner
30 Views

I really don't want to rewrite 20000 lines of code.

0 Kudos
Highlighted
Valued Contributor I
30 Views

if you just want to hack the code for a one-time project, understandable. If that is a code you want to maintain for the upcoming years, it is for sure worth to refactor it and write it as valid Fortran.

0 Kudos
Highlighted
Black Belt Retired Employee
30 Views

You can't guarantee that it will use the size of one side of assignment or the other, if you turn off automatic reallocation. Maybe it works the way you want it now, but a compiler change might cause it to use the size of the larger array. Indeed it may already be doing that and you haven't noticed yet.

Your code is fundamentally broken. Please fix it before you encounter problems.

0 Kudos