Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

Unable to extract recent software downloads. CRC error on files

New Contributor II

A desperate cry for ideas.  We have tried everything we can think of.  I will also contact Intel support.

I am unable to extract the software from any recent software downloads on Windows.  All machines are recent Windows 10 Professional.  Three in a small corporate domain and one stand-alone at home.

For example, when I run VTune_Profiler_2020_setup.exe I get an error message

Error while extracting file:
Crc is mismatched

I have tried

  1. Downloading the file again, and also from home.
  2. Disabling (as best I can) any virus scanners (AVG and remnants of Microsoft Defender at work.  Windows Defender at home)
  3. Other machines at work
  4. Another machine at home

I have gone back over my older downloads

  • VTune_Amplifier_2019_update3_setup.exe OK
  • VTune_Amplifier_2019_update4_setup.exe OK
  • VTune_Amplifier_2019_update5_setup.exe OK
  • VTune_Amplifier_2019_update8_setup.exe FAIL
  • parallel_studio_xe_2019_update1_professional_edition_for_fortran_setup.exe OK
  • parallel_studio_xe_2019_update5_professional_edition_for_fortran_setup.exe OK
  • parallel_studio_xe_2020_professional_edition_for_fortran_setup.exe FAIL

I have opened these files using7-zip.  They all open.  I can extract all the files above marked OK.  When I try to extract the files marked FAIL I get CRC failures on the files - there are several.

The breakage seems too systematic to be random file corruption.  Either something at this end - across multiple machines - can't read them or they are systematically damaged when downloaded.

I haven't tried re-downloading any of the known good files again.  These were downloaded some time ago.  For some reason downloads from the intel site are really slow for the last month or so - up around 400kb/s on a 200Mb/s fibre link.  I'l give it a go from home tomorrow.

0 Kudos
7 Replies
Black Belt

Here a couple of things to try:

  • After downloading the package, find the checksum (MD5, CRC32, etc.) and compare with an established/published checksum value. Intel used to provide CRC32 checksums, but seems to have stopped doing so since a couple of years ago: .
  • Rather than download the full package, download the "online installer", which is only 20 - 30 MB, and select only the essential components for your intended needs. You may add the other components at a more convenient time later.

You can use the MS fciv utility to obtain the MD5 checksums. Here is the checksum that I found for the Fortran composer online installer:

          273e5cbd01ff87cb55aeacbe2ceda313 parallel_studio_xe_2020_composer_edition_online_setup.exe


New Contributor II

I have downloaded a selection of these files from a linux box at home using wget.  These work, so immediate problem is resolved.

Don't know why I got corrupt downloads: (1) at work using chrome, (2) at home using firefox.  Files are correct length.  Will compare checksums when back at work tomorrow.

Prefer to download the full packages.  All the developers can use the same file.  Also, we are having issues with the Fortran compiler (debugger crashes several times a day for multiple developers) and VTune Profiler (doesn't recognise CPU).  In the middle of testing different versions so a bit of installing/uninstalling.

Black Belt

Similar problems with

Also, Windows Defender reports unknown publisher and blocks install.

Black Belt Retired Employee

It seems evident that something is corrupting the downloads, either in the process or afterward.

New Contributor II

Clearly a file corruption issue.  It looks to me like a server-side problem.  As an example I have downloaded the latest MKL 2020 installer w_mkl_2020.0.166.exe multiple times

  1. Chrome/Windows 10 at work
  2. wget / windows 10 at work
  3. Firefox / Windows10 at home
  4. wget / windows 10 at home
  5. wget / linux at home

Get identical MD5 checksums for each download.  The files won't uncompress due to CRC failures on the files.

$ md5sum w_mkl_2020.0.166.exe
b3f51ae83a52f63d40390f6db7abc307 w_mkl_2020.0.166.exe

Anyway, I have managed to get usable copies of the files I need.  I will follow up with intel support.


I have similar problems with Going to go back to older versions until I find one that is stable for now until this is fixed.

New Contributor II

This was resolved in late February - see

My service request 04477676 was passed on to Akamai.  They repeatedly poked and prodded the Melbourne, Australia server until it behaved.

I downloaded 5 good files in a row.  My success rate in the past was < 50% (probably much worse).  At that rate the chance of 5 consecutive successes is < 0.5^5 = 3%.  Good enough to claim provisional victory.