Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27087 Discussions

Using VS19 to compile, getting error LNK1104: "cannot open file ifconsol.lib"

chrisfurlong
Beginner
1,003 Views

Hello everyone, 

I am using VS19 C++ compiling tools and IFORT 21 to compile a solution made up of 93 projects.

I get errors when I try to build the solution, as mentioned in the subject. 

I did some reading and searching and found that a possible solution would be to include the path to the Fortran lib in the Microsoft.Cpp.x64.user property, under VC++ Directories (If you can help me, please check how I have configured this in the image below). The solution I referenced was here: Configuring Visual Studio for Mixed-Language Applications 

I also found instructions for the more recent version of IFORT, but I don't understand them: Building Intel® Fortran/C Mixed-Language Programs (Windows*) 

The first solution didn't seem to do anything and I don't understand how to implement the second solution.

I would appreciate any help, please. 

Regards, 

Chris

 

Labels (1)
0 Kudos
4 Replies
mecej4
Black Belt
963 Views

I do have the latest classic Ifort and the new Ifx compilers installed on Windows 10-64, but I do not find the environment variable IFORT_COMPILER21 defined, either in the system environment or in the Ifort/Ifx command window. I do see IFORT_COMPILER20 defined.

You could see if changing the entry you have for "Library Directories" in your VS configuration (4th line) from IFORT_COMPILER21 to IFORT_COMPILER20 takes care of the problem (try at your own risk).

It is unfortunate that we have a plethora of version numbers within a single release of the compiler package.

chrisfurlong
Beginner
941 Views

Thank you much for the quick reply @mecej4

Unfortunately, making that change doesn't seem to make much of a difference.

I tried pointing the library path and directory path to IFORT_COMPILER20, but I still get similar errors. 

This time I have attached the error list and my vc++ properties config. I get 11 or 12 errors, and they all seem related to Fortran compiler, so I wonder if I have a larger issue?

Thank you for replying earlier, I really appreciate any support.

Kind regards

Steve_Lionel
Black Belt Retired Employee
915 Views

Use IFORT_COMPILER19 . Really. 

Screenshot 2021-03-24 114329.jpg

I'm struggling to refrain from saying what I really think of Intel's current installation development, testing and management. This is at least the third customer-hostile aspect of the oneAPI installer I know of.

Intel support knows about this, and supposedly it will be fixed in a future update, so don't be surprised if it changes again.

 
JohnNichols
Valued Contributor II
904 Views

@Steve_Lionel  - LOL tell us what you really think. 

This is of course the unintended consequences of simple changes -- I actually think someone decided to look at it and make simplifications - they just did not fully test it -- but in the long run the Croods will outlast the Betterman's. 

@Steve_Lionel  love your side bars I am now keeping a running tally - it is 2 today 

Reply