Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

error related to


Hello Sir,

I have successfully installed "l_fcompxe_2015.1.133_redist" recently on Ubuntu 20.04. I am following the instruction as given by the manual which says "source / opt/intel/composer_xe_2015 .1.133/bin/ intel64" in order to make ifort a system-wide command. I constantly get same error saying "No such file or directory". I also have tried some variations in command like folowing.

source /opt/intel/l_fcompxe_2015.1.133_redist/bin/ intel64

source /opt/intel/l_fcompxe_2015.1.133/bin/ intel64

source / opt/intel/composer_xe_2015 .1.133/bin/ intel64

As given in manual default installed path shows "/opt/intel/" so follwed that one. But in my system it shown installation location as "/home/ryzen/". So, I also tried changing path from "/opt/intel/" to "/home/ ryzen/" but still no luck. I am looking for solution from two days. I don't know where else to search for.  I can go forward without this. I need to install Open-MPI after that.

Can anyone help me with this..??

0 Kudos
6 Replies
Black Belt

What is your objective? If you actually intended to install only the redistributable package, you probably have it installed, but that package only contains the runtime support and, possibly, some documentation. It does not contain the compiler, utilities, static libraries, modules, etc.

The purpose of a "redist" package it to enable running a.out-s and shared libraries that were built on a computer (usually, a different computer) that had the full compiler package installed. Most notably, such a redistributables package will not contain the Intel Fortran compiler driver, ifort.

Black Belt Retired Employee

Also, the mention of /opt/intel (for the compiler, not the redistributables) assumes that you didn't override the default install path. But as @mecej4 says, you didn't install the compiler so you are not likely to even have

I'll also observe that you're asking about a six-year-old version.


Yes. This is older vesion. The package (cosmoMC) I want to install is not compatable with the most recent version of Intel Fortran.

So, basically I wanted to install this "Intel Parallel Studio XE 2015 Update 1" but unable to do so. I'm not finding any proper link. How can I install it?

Assistance is much appreciated.

Black Belt

The CosmoMC Readme file says,

"...To run compile and run CosmoMC you will need a Fortran 2008 compiler. Various options include

  • Intel Fortran 14 or higher (earlier versions will not work). ..."

I see no reason why the current Ifort compiler would not work.

If you really want the old compiler, you may need to purchase a license for the product, if you do not already have such a license, and then make a special request to Intel product support to make the old version available to you for download.

Valued Contributor II

mecej4 and SL are correct. Download the latest oneAPI compilers, they are free. The latest compiler will always compile any Fortran - but it may also pick up errors the older compilers did not and you can correct the errors. 

I have code back to 1968 on my machines and Intel compilers will work as long as you avoid the Powerstation disaster.