Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
318 Views

intel parallel studio XE 2016 - composer edition and fortran only version

Jump to solution

Hi can anyone share the installer for the above mentioned version. I could not find on the intel website. the oldest one they have is 2017 version. and also the product serial number of that version. 

Your help is much appreciated. 

Thank you. 

karthi 

0 Kudos

Accepted Solutions
Highlighted
Black Belt Retired Employee
280 Views

You would be mistaken. Use the current version. If you run into problems, we can help you here.

View solution in original post

0 Kudos
14 Replies
Highlighted
Black Belt Retired Employee
304 Views

That would be, um, stealing. There's no good reason to want to use an old version - buy the current one.

0 Kudos
Highlighted
Beginner
300 Views

hi sir,

i would like to link fortran with abaqus 6.14-2. Therefore, for this reason i need that particular version. Other version i don't think it will work. 

thank you.

karthi. 

0 Kudos
Highlighted
Black Belt Retired Employee
281 Views

You would be mistaken. Use the current version. If you run into problems, we can help you here.

View solution in original post

0 Kudos
Highlighted
Moderator
272 Views

Steve is correct, you probably should be using version 17 or newer and should not have issues.  Many Abaqus users use the newer compiler without issue.

If you insist on using a v16 compiler you can open a support ticket and ask for it.   We do keep those archived.  I do want you to consider if you'd install a 5 or 6 year old browser on your system, the browser without any security enhancements over that time.  I would think you would be concerned about bugs.  Similarly with an old compiler you can have incompatibility with  VS2019 and VS2017 (remember when we created v16 was before VS2017), updates, patches, and of course security vulnerabilities. You'll need an OS of that era and VS of that era

https://software.intel.com/content/www/us/en/develop/articles/intel-visual-fortran-compiler-160-for-...

Along with language enhancements, newer compilers have bug fixes AND security fixes to third party tools like the debugger and support libraries.  And newer compilers support modern Visual Studio and all the security patches for it. 

v16 will be unsupported and will not work with VS2019 or VS2017 so it's probably not what you really want.  I would recommend getting PSXE 2019 or PSXE 2020 and try those first.

Again, you can open a support issue and get v16 if you have active support with your license.  Keep in mind you'll need VS2015 and may find it has problems.

0 Kudos
Highlighted
Beginner
134 Views

Hi Ronald, 

I have the same request as the person posting this question. 

I was running Abaqus 2017 with VS 2013 and Intel parallel studio 2016 update 1. Abaqus was running fine with Fortran this way. Unfortunately my Intel parallel studio license expired and I had to download a newer version of Intel as I couldn't find 2016. 

I have tried XE 2020 and XE 2018 and none of them seem to worked with Abaqus 2017 and VS 2013. Would it be possible to obtain XE 2016 for the purposes of using Abaqus and running my models please? I have tried everything with the newer versions and nothing seems to work.

 

thank you, 

 

Arlene Arias

0 Kudos
Highlighted
Black Belt
131 Views

Arlene Arias: "I have tried everything with the newer versions and nothing seems to work."

Please provide a description of what you tried, including a source file and a description of what you tried -- the compiler options used, how the compilation and linking were performed. The probability of getting things to work with a recent version of Intel Fortran is high, and we may be able to give you hints to enable a successful DLL build.

0 Kudos
Highlighted
Beginner
123 Views

Hi, 

 

Thanks for your reply, basically I have followed the instructions in the .pdf attached. I did this last year, and Abaqus was working fine with 2016 version of Intel. 

Since the license expired I downloaded the new license file (for the 2020 version, not sure if this one would enable the use of 2016) and copied it in C drive. This alone didn't seem to work. So the I installed the newer Intel versions and repeated the linking procedure and again I'm getting errors to make it work with Abaqus. 

This is the command prompt I'm using to verify the installation and linking of intel with vs and abaqus 

arlene_0-1606924763742.png

arlene_1-1606924814083.png

then I run this command to verify that it is correctly linked and I'm getting the error. 

arlene_2-1606924947813.pngarlene_3-1606925005060.png

 

Not sure why, as it was working before, only started getting problems when the license expired

0 Kudos
Highlighted
Beginner
99 Views

It looks like there are certain versions of Intel that are compatible with Abaqus 2017 and Visual studio 2013. It doesn't look like the newer versions of Intel are, or at least not 2018 or 2020

0 Kudos
Highlighted
Beginner
96 Views

The attached guide says:

This brief manual describes how to get FORTRAN linking and user subroutines working in Abaqus2017. These instructions have been tested with the following software combination (Microsoft community Visual Studio 2013 + ABAQUS 2017 + Intel Parallel Studio XE 2016 update 4). These instructions may work with other versions but you will need check that Intel Parallel Studio can be integrated to MS Visual Studio and that Intel Parallel Studio does not override MS MPI version coming with Abaqus installation.

 

That's why newer versions of intel might not be working ?

0 Kudos
Highlighted
Beginner
92 Views

This is a compatibility table shared by Abaqus

 

arlene_1-1607001320124.png

arlene_2-1607001416301.png

 

 

0 Kudos
Highlighted
Black Belt Retired Employee
71 Views

That generally means that Abaqus hasn't bothered to test with newer versions. There's no fundamental reason a newer compiler shouldn't work. At most. any Abaqus-supplied scripts might need to be pointed at the installed compiler.

0 Kudos
Highlighted
Beginner
55 Views

I think newer compilers might work and be compatible with newer Abaqus versions (like 2020), however I have Abaqus 2017, which is not compatible with the newer Intel versions. 

0 Kudos
Highlighted
Black Belt Retired Employee
34 Views

You don't know that - only that it hasn't been tested. The only reason it might not be compatible is if there were a bug in one or the other products.

0 Kudos
Highlighted
Valued Contributor III
12 Views

in the post of 02-12-2020 04:03 PM you seem to be in the compiler 16 command prompt but you also seem to be saying that is not installed/working/licenced? If you are trying to use a  later compiler then the command prompt environment for that later compiler will be needed as it will set the correct environment.

It may also be that some ABAQUS scripts  need to be modified to point at the correct (later compiler).

0 Kudos