Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
108 Views

"Parse File..." with lagging visual studio

Hello,

I know this issue has been raised before (e.g. https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/277623). ; However, both my coworker and I are running into this issue.  I am running Intel Fortran 16 Update 2, along with Visual Studio Professional 2013 (Version 12.0.30110.00 Update 1).

I experience significant lagging when working in a free-format file that has many modules (in my case, I have 10 modules in this file) and a lot of lines (currently 3294 in mine).  If I restart Visual Studio, the lagging goes away, but soon returns within a couple of hours.  Eventually it takes several seconds to register even a single keystroke.

I have set all my Advanced Fortran options to False (with the exception of Disable Database, which is set to True).  This helped some of the lagging initially, but I'm still experiencing the several second lag after working on a file for a couple hours.  I notice that when I type "use", the IDE gives me the names of the modules in the file for me to choose from.  Perhaps some of the Advanced Options are not registering correctly?  I also notice that whenever I press a key, the "Parse File xxx.f90" string appears in the status bar.  I'm not sure what it's parsing if all my advanced options are set to false.

Are there more options for me to fix this problem?

Thanks,

Steve

0 Kudos
23 Replies
Highlighted
85 Views

Did you restart VS after changing the Advanced options? 

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
85 Views

Yes, I changed the advanced options a couple months ago and have restarted VS several times since then.

0 Kudos
Highlighted
Beginner
85 Views

I've submitted a ticket for this issue - reference number: 6000159964.

0 Kudos
Highlighted
Employee
85 Views

Thanks for filling the IPS ticket, and for attaching a file that should reproduce the issue.  I couldn't, but I understand you need to modify the file in VS2013 for a long time to see the problem..  I've reported this to the developers, internal tracking number DPD200410144. 

Patrick

0 Kudos
Highlighted
85 Views

Hi all,

Me and my colleagues are still facing this issue. Can I open a new ticket? Or should I continue the discussion in this thread?

The problem is: upon every key press/edit action in an editor window, the status bar displays "Parse file bla.F90", *even though* I disabled all advanced Fortran editor options (and set disable database to True).

Details:

* Intel® Parallel Studio XE 2019 Update 2 Composer Edition for Fortran Windows* Integration for Microsoft Visual Studio* 2017, Version 19.0.0050.15

* a solution with some 20 projects underneath and 100+ Fortran files, some of them over 50kLOC. (I can provide an example zip file when necessary)

 

0 Kudos
Highlighted
Black Belt Retired Employee
85 Views

I suggest opening a new ticket. But first try Update 4.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
85 Views

Thank you for your fast reply. I will open a new ticket.

I can't try Update 4 yet, as I'm waiting for the sysadmins to upgrade to Intel License Manager 2.9.
I'm not so optimistic that Update 4 will do the job, though. This behavior has been in since 2017 or so. It would be no problem for us to do without any of the IntelliSense/advanced editing features, but the thing remains that these can not be switched off for a 100%.

0 Kudos
Highlighted
Beginner
85 Views

Thanks Steve.  Update 4 still produces the issues.  Our team has since transitioned to a different IDE because the lag has been so difficult to work with.

0 Kudos
Highlighted
Beginner
85 Views

Just to confirm, I have the same problem. Whenever it appears, I close Visual Studio and open it again. Then it works fine until after some time (>several hours), the lagging starts to occur again. Then I need to close Visual Studio again... I think this behavior exists for at least more than 1 year. Maybe it started since the AutoCompletion of the Modules has been introduced after one has typed "use " into the source code in the modules section. But maybe it has been there for many years already. I cannot remember exactly. I usually have many .f90 files open and also very long files.

Stefan B.

0 Kudos
Highlighted
New Contributor I
85 Views

This has been a problem for years. The "advanced" options for the VS integration have been a great disappointment since they were introduced. They've never worked right in any version I've tried.

The combination of Visual Studio Code + fortran-language-server (both free) works pretty well for me. I've switched to that for all Fortran editing purposes.

0 Kudos
Highlighted
New Contributor II
85 Views

This is the first time I've heard of VS Code.  Interesting.

0 Kudos
Highlighted
Valued Contributor III
85 Views

Just to say #10 accurately describes my experiences in VS 2017

0 Kudos
Highlighted
Beginner
85 Views

I also have had this problem for many years using Visual Studio and Intel Fortran. I have used VS 2013, 2015, and 2017, and Intel Fortran (with various updates in between)  2011, 2013, 2015, 2016, 2017, 2018, and 2019.

The behavior is always the same. After editing Fortran code for more than 30 minutes or so, the typing starts to lag, to the point where it takes multiple seconds for a single keystroke to appear on the screen. My only solution is to restart Visual Studio. It is extremely frustrating.

It seems to happen faster, and more severe, when editing large Fortran files (thousands of lines), and those with many "use" statements in the functions. However, this might just be because all of our large Fortran files have lots of "use" statements.

 

0 Kudos
Highlighted
Black Belt Retired Employee
85 Views

The USE statements aren't relevant. The editor is trying to rescan the whole source for things such as parenthesis matching. I remember when I was working on IFWINTY I would have to create a separate file with my changes and then paste it in, as the editor was so slow.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Valued Contributor III
85 Views

Steve Lionel (Ret.) (Blackbelt) wrote:
The USE statements aren't relevant. The editor is trying to rescan the whole source for things such as parenthesis matching. I remember when I was working on IFWINTY I would have to create a separate file with my changes and then paste it in, as the editor was so slow.

That may well be the case but it is initially OK but gets slower with the passage of time. The file edits are insignificant as part of the whole. It is like there is some sort or resource leak that eventually forces a VS restart. 

0 Kudos
Highlighted
New Contributor II
85 Views

Interestingly I see no sign of this using VS2005 with IVF.  Sometimes the old ways are best ;).

0 Kudos
Highlighted
85 Views

Steve Lionel (Ret.) (Blackbelt) wrote:

I suggest opening a new ticket. But first try Update 4.

 

Hi Steve, it feels a bit awkward to ask this question to you, being retired from Intel nowadays. But: can you (or anyone) point me to a working e-mail address to which I can submit my support ticket?

I am getting errors logging into the priority support pages, the phone support people have pointed me to an e-mail adress (supportreplies@intel.com), from which I am getting errors "your message was not delivered".

How can I access my paid support if all of the above options don't work?

0 Kudos
Highlighted
Black Belt Retired Employee
85 Views

See if https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/761817 helps - it gives a different email for help with login issues. Also, Devorah or one of the other Intel folks might see your complaint here and contact you offline. Submitting by email is probably not an option.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Employee
85 Views

I tried the original test with ~9k lines provided via Intel Support page with latest Intel Fortran compiler version 19.1 and VS2017 (15.9.17) and all advanced text editing features enabled. I have not observed this issue. Please open a new ticket with steps to reproduce this lagging.

0 Kudos