Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
15 Views

warning #5117: Bad # preprocessor line

I'm trying to compile a fortran project with /fpp option on visual studio 2013, and it keeps giving me a warning:

warning #5117: Bad # preprocessor line

And it looks like the code hasn't been passing through to the preprocessor.

The code is as simple as this:

      logical*1 FUNCTION IsPreprocesorDefined()
      
      IsPreprocesorDefined= .false.
      
      #ifdef  PRO_PROC_DEFINED
      IsPreprocesorDefined= .true.
      #endif
      
      return
      end

The compiler I'm using is Intel(R) Visual Fortran Compiler XE 15.0.4.221 [IA-32]

Can anyone point me to the right direction?Thanks very much

0 Kudos
3 Replies
Highlighted
Beginner
15 Views

hello anyone?

hello anyone?

 

why the status of the post is still draft?

0 Kudos
Highlighted
15 Views

Please attach a ZIP of the

Please attach a ZIP of the buildlog.htm showing the error. I'd expect this message if in fact /fpp wasn't being used.

Retired 12/31/2016
0 Kudos
Highlighted
15 Views

Did you change this option to

Did you change this option to all your project files... and build platforms?

Are you adding this switch to the "miscellaneous"/additional options...
... or did you check the Preprocess(or) check box in the VS Project properties? (and for all builds)

Jim Dempsey

0 Kudos