Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
87 Views

Intel Core i7-7700K GPU Drivers Problem with CentOS 7

Hello All,

I am using CentOS 7.2.1511 (Gold Edition) for Intel Media SDK 2017 R2 to use the Intel QuickSync Technology for trans-coding video files,

I have install the Intel Media SDK with no problem and followed the steps in this documentation: https://software.intel.com/sites/default/files/media_server_studio_getting_started_guide.pdf

But when running the Intel System Analyzer for Linux https://software.intel.com/en-us/articles/mss-sys-analyzer-linux

I got this error :

 

# ./sys_analyzer_linux.py -v

--------------------------

Hardware readiness checks:

--------------------------

[ OK ] Processor name: Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz

[ INFO ] Intel Processor

[ INFO ] Processor brand: Core

--------------------------

OS readiness checks:

--------------------------

[ INFO ] GPU PCI id : 5912

[ INFO ] GPU description: unknown

[ ERROR ] No compatible GPU available. Check BIOS settings?

 

 

I have tried to check the lspci:

# lspci -nn -s 0:02.0

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:5912] (rev 04)

 

Also i doubt the problem was from the BIOS, I have checked the BIOS configuration and it was already enabled "iGFX" under peripherals menu.

Tried to install Windows 10 to be sure, It's worked fine without any problem,

But i still need to use the CentOS.

 

Here are some info about my hardware:

Motherboard Model: GIGABYTE GA-Z270M-D3H (rev. 1.0)

BIOS Version: F5

CentOS Linux release 7.2.1511 (Core)

0 Kudos
1 Reply
Highlighted
Employee
87 Views

Hi Areeb,

I'm sorry you are running into issues.

It sounds like you are trying to figure out why Media SDK is not recognizing your Intel GPU in your system, correct?  If so, I will need to direct you to the Media forum where they will be able to help with your issue more than I can.

0 Kudos