Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
440 Discussions

Could not solve the Error: Modelsim (vsim) is not on the path in HLS.

SOZDO
Beginner
881 Views

Hi, I am so new to Intel FPGA products and softwares, I have installed Quartus Prime 18.1 Standard Edition / Model Sim - Intel FPGA Starter Edition 10.5b and Microsoft Visual Studio 2010 Professional as it is said in Intel High Level Synthesis Compiler Getting Started Guide. My quartus prime installation directory is "D:" since there is not enough disk space on "C:". Then I follow the steps to initialize Intel HLS Compiler Environment.

I have set user variables environment path and system variables environment path as given in picture then closed and reopened Visual Studio 2010 command prompt and tried again but I still got the same error given in picture. hls.JPGuser variable path.JPGsystem variables path.JPG

0 Kudos
6 Replies
AnandRaj_S_Intel
Employee
442 Views

Hi @SOZDO​ ,

 

Restart the system/PC after setting the variables environment.

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Regards

Anand

SOZDO
Beginner
442 Views

Hi @Anand​ ,

I have tried this method but unfortunately it did not work. I still got the same error. I have searched in forums and internet but could not find anything.

 

AnandRaj_S_Intel
Employee
442 Views

HI,

 

The Error: Modelsim (vsim) is not on the path is related to environment variable. Which is used to check that we have Modelsim in our path.

 

I have below setting which is working fine.

PATH=C:\intelFPGA\18.1\modelsim_ase\win32aloem

VisualStudio=C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin

QUARTUS_ROOTDIR=C:\intelFPGA\18.1\quartus

 

Kindly retry by restarting the system also check if you have vsim.exe under C:\intelFPGA\18.1\modelsim_ase\win32aloem

 

Regards

Anand

 

SOZDO
Beginner
442 Views

Hi @Anand​ ,

I have exactly same sttings with you except my quartus prime paths are under "D:", does it change anything?

There also exists vsim.exe under win32aloem.

AnandRaj_S_Intel
Employee
442 Views

​Hi @SOZDO​ ,

 

Just checked init_hls.bat file but I find any clue.  Also bat file is working from current directory and it set current directory as ROOTDIR.

 

I will work on it and update you soon.

 

Regards

Anand

VMalv
Beginner
442 Views

@Anand​ 

I have same configuration of environment USER variable as specified. Still I am getting the same error. I tried lot of things but still can not figure that out!

Reply