Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
561 Discussions

Max10 Support with HLS 19.1

FabianO
Novice
422 Views

Hi everyone,

 

when trying to compile the provided counter example for the Max10 architecture, i get the following error:

C:\intelFPGA_lite\19.1\hls\examples\counter>i++ -march=Max10 -ghdl counter.cpp
Error: Unsupported device family. Supported device families are:
Cyclone10GX, Arria10, Stratix10

Is there no support for Max10 devices with the hls compiler version 19.1? If no, which versions of HLS do include Max10 support?

I´m using Windows 10, HLS version 19.1 Pro, Quartus Prime 19.1 Lite with Simulink and Max10 support, MVS2015 Community Edition

 

Thanks in advance!

0 Kudos
1 Reply
AnilErinch_A_Intel
316 Views

Hi ,

Intel HLS compiler edition 18.1 support max 10.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/hls/archives/ug-hls-18-1...

Thanks and Regards

Anil


Reply