Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
440 Discussions

No OpenCL BSP and driver (v19.1) for Arrow SoCkit GSRD November 2019 edition (Rockerboards.org)

DMerc4
Beginner
401 Views

Hi

I am trying to use OpenCL with the Arrow SoCkit, I have it working with the GSRD v14.0 July 2017 Edition which works with the Quartus standard edition v14.0/14.1. 

https://rocketboards.org/foswiki/Documentation/ArrowSoCKitEdition201707

Rocketboards provide a tutorial for getting started with OpenCL:

https://rocketboards.org/foswiki/Documentation/ArrowSoCKitOpenCL

This tutorial provides a BSP and microSD card image with the July 2017 GSRD, built driver, v14.0 BSP and v14.0 RTE preinstalled. Unfortunately I only have a paid licence for v19.1 of Quartus and OpenCL not v14 and I am not able to purchase a license for v14. Therefore I have tried to use the available files with v19.1 of Quartus/OpenCL but they do not work.

I have tried importing the BSP into Quartus v19.1 to upgrade the IP blocks but this failed and the BSP does not work. The compiled driver provided with the v14 BSP also does not work with the November 2019 version of the GSRD v19.1. Please can someone provide the v19.1 BSP and v19.1 built driver for the Arrow SoCkit November 2019 edition, as I cannot find these files anywhere? If someone could also update the full tutorial and files above for v19.1 and November 2019 edition that would be even better. A link to the November 2019 edition is below.

https://rocketboards.org/foswiki/Documentation/ArrowSoCKitEdition201911

Many thanks

Dan

0 Kudos
3 Replies
AnilErinch_A_Intel
289 Views

Hi ,

Please get in touch with the local sales team and check that whether they can provide you a trail version of the required OpenCL BSP.

Thanks and Regards

Anil


DMerc4
Beginner
266 Views

Ok, so I have v5.4.84 of altera-opensource/linux-socfpga up and running on the Arrow SoCkit with GHRD 19.1. The only thing missing is an OpenCL driver that works on v5 of the kernel. I think that there have been a number of changes to the way fpga_manager implements fpga bridges since v4 of the kernel so the old driver does not work. I have contacted my local office but they do not have an updated driver, they only have a driver for v14.1 of Intel FPGA SDK for OpenCL, for which it is no longer possible to purchase a license. I have also found out that the sopc2dts tool has been dropped because it is faulty, so a working device tree setup to go with it would be good too. I have no way to confirm if the GHRD 19.1 device tree files work because I do not have a working driver. Currently I can find no way to use OpenCL on the Cyclone V without Quartus 14.1 for which it is no longer possible to purchase a license. I really think Intel should include the license for Intel FPGA SDK for OpenCL v14.1 with the newer versions of Intel FPGA SDK for OpenCL. My companies Quartus license covers all the latest versions of the Intel FPGA SDK for OpenCL, such as v19.1, but not older versions such as 14.1 and it is no longer possible to purchase a license for v14.1, so why not make it free or atleast include it for free in a paid subscription?

In summary:

1. I would like a working OpenCL driver for the Arrow SoCkit that works with v5.4.84 of the kernel and GHRD 19.1.

2. Some solution to the device tree issue as I understand that the sopc2dts tool is unreliable and has been dropped.

3. To make free or include in paid licenses all older versions of Intel FPGA SDK for OpenCL for example v14.1, otherwise you are preventing people from using it and this is currently the only version that will work with OpenCL on the Arrow SoCkit.

Yours sincerely,

Dan

DMerc4
Beginner
256 Views
I just wanted to add that the latest driver source in Intel FPGA SDK for OpenCL v19.1 standard will not work because it tries to set the irq number rather than request which irq to use from the kernel, therefore this source will not work in v5 of the kernel. Is someone at Intel maintaining this driver? If so it would be good if it was in github.com/altera-opensource . It makes sense for Intel to maintain the driver and source tree because Intel is part of the consortium implementing all these changes to fpga_manager .
Reply