Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
663 Discussions

Opening text editor in Quartus Prime Pro

HansHolland
Novice
1,165 Views

My project consists of only one AHDL text file. How do I open a text editor to be able to type in this TDF? Sorry for this basic question; just starting Quartus, however I did a lot of AHDL in the past. Thanks

0 Kudos
1 Solution
HansHolland
Novice
986 Views

Issue resolved!

My file had a double extention <name>.TDF.txt   Ater removing .txt, it was recognized by Quartus. 

Thanks Sheng

View solution in original post

0 Kudos
6 Replies
HansHolland
Novice
1,126 Views

Shouldn't be too hard and too much to ask. Want to type-in TDF to get a config. bit stream produced. Failed using my own text editor and use "add design file" or something, trying to find example tutorial, etc. etc.

0 Kudos
ShengN_Intel
Employee
1,029 Views

Hi HansHolland,

 

If I'm not mistaken, you want to open the .tdf file and then edit it with Quartus pro right?

 

  1. Click the "File" at the top bar of Quartus pro,  click ''Open'',  select .tdf file type and open your own TDF file.
  2. Or straight click the ''Open'' located at bar below.
  3. Or click the ''Files" near ''Project Navigator'' window, double click it, click ''...'', select your TDF file, click ''Apply'' and click ''OK''. Double click the added file to open text editor.

 

Hope it helps.

 

Best regards,
Sheng


0 Kudos
HansHolland
Novice
1,016 Views

Hi Sheng,

Option 3. you mention, results in  "Can't find design entity <filename>" error. I cán see my TDF in the Quartus editor.

Trying to compile, results in "Top-level design entity <filename> is undefined" error.

0 Kudos
ShengN_Intel
Employee
1,012 Views

Hi HansHolland,

 

Make sure that TDF is set as top level entity by right-clicking that file and click ''Set as Top-Level Entity''.

 

Also, make sure filename matched with the name after module.

 

Best regards,
Sheng


0 Kudos
HansHolland
Novice
987 Views

Issue resolved!

My file had a double extention <name>.TDF.txt   Ater removing .txt, it was recognized by Quartus. 

Thanks Sheng

0 Kudos
ShengN_Intel
Employee
978 Views

Hi HansHolland,

 

I’m glad that your question has been resolved.

 

I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

 

Best regards,
Sheng

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos.

0 Kudos
Reply