Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MLutt
Beginner
156 Views

What are the compiler requirements for HLS with Quartus Prime Lite 19.1?

Hi,

 

I am using Ubuntu 18.04. I have Quartus Prime Lite 19.1 installed and it is running okay, including ModelSim and the Nios II software development kit.

 

I installed the HLS available for Lite 19.1. The file makes it sound like the Pro version, but I doubt that.

 

When I try to compile anything with i++, I get errors such as missing bits/c++config.h or __builtin_labs and __builtin_llabs.

 

The getting started guide for HLS Standard, says it only works with gcc 4.4.7. The getting started guide for HLS Pro says it only works with gcc 9.1.0. Neither is available with Ubuntu 18.04.

 

The version of i++ is 19.1.

 

What version of gcc do I need for HLS with Quartus Prime Lite 19.1?

 

Thank you.

0 Kudos
5 Replies
116 Views

Hi ,

The latest version of OS officially supported for 19.1 is Ubuntu 16.04 as you can see from the below link.

https://www.intel.com/content/dam/altera-www/global/en_US/others/download/os-support/readme_qp191.tx...

But if you would like , you can try to use GCC version 4.4.7 in Ubuntu 18.04 for the compilation and let us know results.

Thanks and Regards

Anil

MLutt
Beginner
116 Views

Hi,

 

Just as a side note - Ubuntu 16.04 is no easy fix for Quartus. When I initially had issues getting Quartus Prime Lite 19.1 running under Ubuntu 18.04, I installed Ubuntu 16.04 hoping that it would solve the issues since it is the officially supported version. But it did not fix anything. So I went back to Ubuntu 18.04. I had to do many things to get Quartus to run without any errors. Getting ModelSim and the Nios II EDK running were equally frustrating. But I eventually got them working. I found other people on the internet had run into the same issues.

 

GCC version 4.4.7 is not available in Ubuntu 18.04 nor Ubuntu 16.04, but it is available in Ubuntu 12.04. So I installed a chroot environment with Ubuntu 12.04 in my Ubuntu 18.04 system. I manually installed gcc 4.4.7 (because it was still not the default version). I had to install a few libraries and add an include directive for the compiler. I don't have ModelSim working yet under Ubuntu 12.04.

 

But by using both Ubuntu 12.04 for gcc and Ubuntu 18.04 for i++, I have been able to successfully make the /hls/examples/tutorials/usability/compiler_interoperability fpga_testbench.

 

It shouldn't be this difficult. I'm only putting up with this software mess because there is some hardware I want to use.

 

Mike

HRZ
Valued Contributor II
116 Views

Using CentOS could have saved you a lot of time; CentOS is by the far the best-supported OS for FPGA development both for Intel and Xilinx. Also you can manually compile any version of GCC from source on any OS, you don't need to go all the way back to Ubuntu 12.04 which reached its end of life a long time ago to get access to GCC 4.4.7.

MLutt
Beginner
116 Views

HRZ, Thank you for the suggestions. I did start down the CentOS 7 path a few days ago. I ran into some display issues (I was running it inside a virtual machine), so I stopped pursuing that path. Maybe I’ll revisit that. I also considered compiling gcc 4.4.7. I was concerned about having multiple versions of gcc installed. Maybe I could have handled that with the alternatives mechanism. The chroot approach has been working well for me. It keeps the older version of gcc completely separate from my normal system. And it is fairly easy to work with in its own terminal shell. I have it setup to share the home directory. So I can just switch between terminal shells to switch between Ubuntu versions. Mike Lutton Electrical Engineer MAGNA ELECTRONICS 2050 Auburn Rd., Auburn Hills, MI 48326 OFFICE 810-606-8655 michael.lutton@magna.com<mailto:michael.lutton@magna.com>
116 Views

Hi ,

Glad to know that you have managed to solve the issue.

Thanks and Regards

Anil

Reply