Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
441 Discussions

X2go timing out local host connection

Dr_FPGA
Novice
1,533 Views

Hi,

I am following similar instructions as in this thread:

https://community.intel.com/t5/Intel-High-Level-Design/X2GO-client-connection-failure-Socket-Disconn...

However in my case X2go connection to localhost times out. Please see the attached picture.

I am able to connect to devcloud with PuTTY in terminal mode. AWS and NIMBIX GUI work fine in my environment.

I already dropped all firewalls: soft and on the router, still the same result. Please advise what the next step.

Thank you.

 

0 Kudos
1 Solution
Lawrence_L_Intel
Employee
1,511 Views

Which compute node are attempting to run X2Go on? You can check X2Go status with systemctl status x2goserver. Did you run the tunneling command from your local (PC) terminal, not the login-2 node? X2go doesn't run on all nodes. Best of luck, if you are still stuck, send me a few times for a quick conference call.

Cheers

Larry

View solution in original post

3 Replies
Lawrence_L_Intel
Employee
1,512 Views

Which compute node are attempting to run X2Go on? You can check X2Go status with systemctl status x2goserver. Did you run the tunneling command from your local (PC) terminal, not the login-2 node? X2go doesn't run on all nodes. Best of luck, if you are still stuck, send me a few times for a quick conference call.

Cheers

Larry

View solution in original post

Dr_FPGA
Novice
1,503 Views

Hi Lawrence,

I missed the second terminal ssh command. After I followed exact instructions in section 6.0

https://github.com/intel/FPGA-Devcloud/tree/master/main/Devcloud_Access_Instructions

I was able to connect with X2Go in GUI mode.

Thank you.

BoonBengT_Intel
Moderator
1,486 Views

Hi @Dr_FPGA,

Hope this message find you well and good to know that it is working now, we would be closing the thread. If you have further queries, Please do post a response in the next 15 days.

After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions.

 

Warm Regards

Reply