Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Vaclav_L_
Beginner
148 Views

SDE ERROR: Cannot execute XGETBV with ECX != 0

Hi,

I have troubles with running Intel SDE for AVX-512 emulation. I've downloaded last version (sde-external-7.49.0-2016-07-07-lin) and run on Debian kernel version 4.9.0-1 x86-64. I do not use SELinux and already disabled 

/proc/sys/kernel/yama/ptrace_scope

 

But execution gives me this error:

$ ./sde64 -skx -- binaryfile
SDE ERROR: Cannot execute XGETBV with ECX != 0.

 at (no-file):65 Function (no-func)

 

Any ideas what went wrong?
Thanks

0 Kudos
5 Replies
AdyT_Intel
Moderator
148 Views

This is a known issue and a fix will be available in our next release.

Roger_G_1
Beginner
148 Views

I am on a sandybridge running Fedora25, how do I get around the XGETBV problem?
I tried 7.58.0 which didn't work.
I googled the XGETBV error message and found your comment.
So I tried 7.49.0, but it didn't work either.
Then I noticed that your comment was for the 7.49.0 version, and it wasn't fixed in the next version 7.58.0.

I tried 7.41.0, 7.39.0 and 7.36.0 and none of them worked.
I even tried 6.12.0, but that didn't support my version of linux.

Roger

AdyT_Intel
Moderator
148 Views

This is a known problem and it was already been fixed in our internal version.
We have no workaround for this problem. 

We will update the external kits soon.

Roger_G_1
Beginner
148 Views

still waiting for the updated release

David_L_4
Beginner
148 Views

Commenting here to say that I had the same problem, but a new external release is now available for download and the bug is now fixed for me.  The release I am using is sde-external-8.4.0-2017-5-23-lin which (judging from file name) was released May 23.

Reply