Intel® MPI Library
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.

libimf.so not found

mevel
Novice
2,821 Views

Ubuntu 18.04

in a terminal, ifort myprog.f90 works and a.out is generated.

 

As I use Code:Block ( IDE) , I get the message libimf.so not found??

 

I can't figure out this

 

 

Labels (1)
0 Kudos
1 Solution
mevel
Novice
2,762 Views

Hi, my problem is fixed.

 

In a previous version of Code:Block, the program was not sensible to special characters. With version 1.7  of Code:Blocks and Intel OneApi, it was not any more the case.

 

After removing Téléchargement  , and creating Telechargement without the character "é"  , It works. That is great, only a dummy character!!

View solution in original post

0 Kudos
4 Replies
mevel
Novice
2,807 Views

I can add, that with c:B, I have no executable : le compiler works but not linkage

0 Kudos
SantoshY_Intel
Moderator
2,772 Views

Hi,


Thanks for reaching out to us.


>>"in a terminal, ifort myprog.f90 works and a.out is generated."

Are you able to run ./a.out in the terminal?


>>"As I use Code:Block ( IDE) , I get the message libimf.so not found??"

Can you provide the steps to reproduce the issue(Commands)?


Thanks & Regards,

Santosh


0 Kudos
mevel
Novice
2,763 Views

Hi, my problem is fixed.

 

In a previous version of Code:Block, the program was not sensible to special characters. With version 1.7  of Code:Blocks and Intel OneApi, it was not any more the case.

 

After removing Téléchargement  , and creating Telechargement without the character "é"  , It works. That is great, only a dummy character!!

0 Kudos
SantoshY_Intel
Moderator
2,755 Views

Hi,

 

Glad to know that your issue has been resolved. We will no longer respond to this thread. If you require additional assistance from Intel, please start a new thread. Any further interaction in this thread will be considered community only.

 

Have a Good day!

 

Thanks & Regards

Santosh

 

0 Kudos
Reply