Intel® NUCs
Support for Intel® NUC products
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

11324 Discussions

NUC10i5 headphones jack audio not working with Ubuntu 20.04

User1588805342964871
10,390 Views

Hi,

 

After installing Ubuntu 20.04 on a new NUC10i5, I didn't have any audio output while the internal mic seemed to be working. After fiddling around with /etc/modprobe.d/alsa-base.conf and adding options snd-hda-intel I was able to get it to show the HDMI audio output option which was a step forward from the Dummy output. Nonetheless, I cannot get the headphone / speaker jack to work.

 

Any ideas?

10 Replies
AndrewG_Intel
Moderator
10,280 Views

Hello User15888053429648719774

 

Thank you for posting on the Intel® communities.

 

It is worth mentioning that for most Intel® NUCs at this point only Windows® has been validated as supported. Linux Operating systems have not been validated yet. Intel® NUCs reported as compatible by Linux users and additional details for Linux support can be found in the below link:

Linux* Support for Intel® NUC.

Linux distributions normally include all necessary drivers. Contact your Linux vendor and use their distribution resources for driver downloads and support.

 

However, we will do our best to check this inquiry. In order to understand better your environment, could you please provide the following information?

 

1- Intel® NUC full model:

2- How many units are affected by this issue?

3- Did the headphone/speaker audio jack work fine before? For instance, with another Linux distro or maybe with Windows® 10 in the case of dual boot?

 

4- Is the Linux Kernel up to date?

5- Have you tried different sound devices/speakers? Are they working fine with other systems?

 

6- Have you checked that the Audio device is enabled in the BIOS?

To check this please review the BIOS Settings Glossary for Intel® NUC based on the BIOS core that your Intel® NUC has.

 

7- Please provide Log file /var/log/dmesg

 

8- Intel® System Support Utility report for the Linux* Operating System

https://downloadcenter.intel.com/download/26735/

Please refer to the Release Notes for details on how to run the tool:

https://downloadmirror.intel.com/26735/eng/ReleaseNotes.txt

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

User1588805342964871
10,280 Views

Hi Andrew G. and thanks for your reply.

 

I understand that you only officially support Windows but you gen 10 NUC seems to almost work perfectly with Ubuntu 20 so if you fix this one audio thing you could claim support for Ubuntu too.

 

Please find my answers below.

 

1- Intel® NUC full model: NUC10i5FNK

 

2- How many units are affected by this issue?

I am guessing all the NUC10ixxxx sold by you including my one NUC10i5FNK

 

3- Did the headphone/speaker audio jack work fine before? For instance, with another Linux distro or maybe with Windows® 10 in the case of dual boot?

This is a brand new machine and Ubuntu is probably the most popular Linux distribution so I tried that one. Please let me know if another Linux distribution will have better chances. I have not tried to install Windows nor would it be my preference to use Windows over a Linux distro.

 

4- Is the Linux Kernel up to date?

Latest Ubuntu 20.04 LTS freshly installed

 

5- Have you tried different sound devices/speakers? Are they working fine with other systems?

Yes have tried different headphones and speakers that are in perfect working condition. Also it is obvious that these are not the issue because only a "Dummy Output" option is available and not the proper Intel HDA Output.

 

6- Have you checked that the Audio device is enabled in the BIOS?

Yes it is enabled and the BIOS has been updated to its latest version. Even before the update of the BIOS the audio output would not work.

 

7- Please provide Log file /var/log/dmesg

Please find attached dmesg-ssu.txt and check top section beginning from line 3

 

8- Intel® System Support Utility report for the Linux* Operating System

Please find attached dmesg-ssu.txt and check bottom section beginning from line 1182

 

KBrow27
Beginner
10,280 Views

I had the similar issue. Thanks for the support. Helpful indeed

User1588805342964871
10,280 Views

I was actually able to fix this through the information I found below:

 

https://askubuntu.com/questions/1059619/sound-card-shown-as-dummy-output-in-ubuntu-18-04 answer by Ron Wellman

https://forums.linuxmint.com/viewtopic.php?t=268499 answer by MrEen

https://askubuntu.com/questions/69820/how-do-i-set-a-pulseaudio-card-profile-persistently-across-reb...

 

The main idea is to run

pacmd list-cards

To get your sound card's info e.g. "alsa_card.pci-0000_00_1f.3" and see the list of profiles and the active profile. In my case, the active profile was the microphone input. You have to change it to "output:analog-stereo+input:analog-stereo" instead. You can run a one-off command that will last you your current session:

 

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

To get these changes automatically applied each time you need to edit /etc/pulse/default.pa by running:

 

sudo nano /etc/pulse/default.pa

and you add the following at the end of the file:

 

set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

The only minor issue is that in the system Settings under Sound the Output Device has a blank option.

swong
Beginner
7,614 Views

Beautiful, that works for me on my new NUC10I7FNH4 running fedora 33.

Sound works over the audio jack once that is done and system rebooted. Only catch is Fedora doesn't show the device as active.

But you only need to choose show inactive device in audio settings to adjust the volume and balance.

Thanks

Steven

 

AndrewG_Intel
Moderator
10,280 Views

Hello User15888053429648719774

 

Thank you for your response and for sharing the details on how you solved the no audio issue. Hopefully, this may help other community members.

 

Please allow us more time to check regarding the minor issue you mentioned about the Output Device with the blank option.

 

Best regards,

 

Andrew G.

Intel Customer Support Technician

Ronny_G_Intel
Moderator
10,280 Views

Hi everyone,

 

We provide very limited support for NUCs not validated with Linux*, we know the NUC10i5FNK works with Linux, especially with Ubuntu* but we haven't done extensive testing so we haven't validated it, check our operating system compatibility list https://www.intel.com/content/dam/support/us/en/documents/intel-nuc/Supported-OS-NUC.pdf

Having that said, I believe it is going to be difficult for us to address this issue and I would recommend that you reach out to the Linux community.

 

Regards,

Ronny G

 

One more thing, thanks a lot for sharing your findings.

jack86h
Beginner
8,877 Views

add "options snd-hda-intel model=dell-headset-multi" to "/etc/modprobe.d/alsa-base.conf"

Then reboot. Works like a charm.

Golfer
Beginner
8,429 Views

New to NUC. New to Linux audio. Read your answer and dismissed it. (I don't have any Dell stuff.)

Messed around for hours learning about Pulse Audio, etc. Eventually figured out that changing "model" couldn't hurt and might be worth trying, so I tried various words I found here and there. Eventually found your answer again and tried it.   Just as you said - works like a charm.

I have a NUC10i7

linuxuser2021
Beginner
7,288 Views

@jack86h Thank you very much for your help. Adding options snd-hda-intel model=dell-headset-multi  to  /etc/modprobe.d/alsa-base.conf  let me use my Sony wired headphones with the Intel NUC10i5FNB on Ubuntu 20.04.2  . Much appreciated.

Reply