Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mluky
Beginner
6,375 Views

NUC7i5BNH and wake on lan

Hello

I have nuc7i5BNH

Help to configure wake on lan, please

Information on the BIOS and settings in the attached pictures.

with such settings, I turn off windows, and turn on using WAL does not work. On the router I see that the cable is not connected to the network card, the LED on the power button does not light. NUC can only be turned on by pressing the power button.

what could be the problem?

0 Kudos
19 Replies
jema
Novice
1,600 Views

For some reason I can't open the pictures so my answer is a generalisation. Do you have some software that sends a wake-up package to the nuc? Just trying to connect with remote desktop will not wake the machine. Unless you tell the nic, in Windows, to wake on any traffic to the machine. The problem with this approach is that the computer will be more awake than sleeping.

Let's not forget the classics. Try with the intel nic driver, not the windows driver. Try putting the nuc to sleep instead of turning it off.

Hope it helps.

mluky
Beginner
1,600 Views

I duplicated the pictures in the cloud and added a few more with the network card settings.

From sleep mode and hibernate mode with WOL Wake NUC can be no problem, everything works.

Waking through the web interface of the router (zyxel keenetic giga II) attached a screenshot.

The driver for the network card was installed from Intel. ver 12.17.8.7

Pictures:

https://yadi.sk/d/P_3O2HwM3SvCoP Nuc — Yandex.Disk

n_scott_pearson
Super User Retired Employee
1,600 Views

The Windows settings have absolutely nothing to do with the situation in S4 and S5. To be able to wake in these states, it is the settings in the BIOS that count.

I see that Deep S4/S5 is enabled (checked). WOL will never work with this set.

...S

jema
Novice
1,600 Views

I still haven't checked your settings against mine but my 7i3BNH refused to wol until I installed the intel nic drivers, I used the default settings. Now it starts when powered off, with or without deep sleep set.

I failed russian badly so I can't tell what it says next to the IP address in the router screenshot. However, what happens if you change the IP address to the broadcast address, ie put 255 on the end?

mluky
Beginner
1,600 Views

Re: NUC7i5BNH and wake on lan

N. Scott Pearson

@I see that Deep S4/S5 is enabled (checked). WOL will never work with this set.

if I understand you correctly, do I need to make" Deep S4/S5 " is disabled?

mluky
Beginner
1,600 Views

@ I still haven't checked your settings against mine but my 7i3BNH refused to wol until I installed the intel nic drivers, I used the default settings. Now it starts when powered off, with or without deep sleep set.

when your 7i3bnh is in the power off state, are the LEDs on the network card glowing?

192.168.1.59 this is the IP address of NUC

The "Разбудить по сети" button translates to English as " Wake on network"

I used this program, but there was no success

http://www.nirsoft.net/utils/wake_on_lan.html WakeMeOnLan - Turn on computers on your network with Wake-on-LAN packet

Maybe the BIOS have some settings to change? Can be related to power supply (energy Saving)?

mluky
Beginner
1,600 Views

Jema,

what driver version do you have installed?

Look at my settings please. If you can not see here, I can send them by e-mail or where you will be convenient.

I disabled in the BIOS Deep s4/s5. From sleep and hibernation modes nuc wakes up . If I do in windows shutdown, it is impossible to awaken. The power button lights orange, the LEDs on the network card do not light.

PS: may be I was not properly shutdown NUC ?

jema
Novice
1,600 Views

I use driver package 22.9.

I might have started the troubleshooting in the wrong end, the nic on my nuc shows link when it is powered off.

The images work now, I'll check the settings as soon as I can.

mluky
Beginner
1,600 Views

I use same driver package PROset 22.9.16.0

I have BIOS version 0060, just checked, the current version of 0062. Tonight will update the BIOS to version 0062.

PS: This is the second instance of NUC7i5BNH and with it the same problem. Today, I'll try another router, maybe the whole problem in the router?!

jema
Novice
1,600 Views

As far as I can tell we have the same bios settings except that I use the balanced power mode and have different led colours. I have also disabled wifi since I don't use it.

My bios is version 60. The 62 is "only" a security update.

If you can try another router or check if there are any power settings on the one you're using.

Other than that I'm afraid that I'm running out of ideas.

Edit: you say that the power led is still on? When I turn my nuc off so does the LEDs. Maybe the machine isn't entering the right power state?

mluky
Beginner
1,600 Views

The router does not have power settings.

Could you show additional NIC settings ?

mluky
Beginner
1,600 Views

BIOS updated, the router another established, the problem isn't solved.

conducted three experiments

The experiment first.

1. Turned on the NUC, windows 10 is loaded. I'm correctly using the "start" button, turn off the NUC.

2. NUC is turned off, the power button glows orange, the led is not lit on the NIC and wol is not working.

In the second experiment.

1. Turned on the NUC, windows 10 is loaded. I'm correctly using the "start" button, turn off the NUC.

2. NUC is turned off, the power button glows orange, the led is not lit on the NIC and wol is not working.

3. I de-energize the NUC (pull the power adapter out of the 220 volt outlet).

4. Supply power (insert power adapter 220 volt in the socket). The NUC is illuminated by an orange power button, the led on the network card lights up. In the interfes of the router I see that the network card is anti-theft, wol does not work.

A third experiment.

1. Turned on the NUC, windows 10 is loaded.

2. I de-energize the NUC (pulling the power adapter out of the 220 volt outlet, not through the "start"button).

3. Of course, the NUC is turned off is not correct.

4. Supply power (insert power adapter 220 volt in the socket). On the NUC the power button lights orange, the led on the network card lights up, wol works fine.

It turns out that windows turns off as strange NUC. Maybe someone have ideas what is the problem?

Windows 10 pro x64

jema
Novice
1,600 Views

I checked the settings for the nic that you have posted and I have the same ones.

Judging by your experiment it certainly seems to be power related but I can't figure out how our machines differ.

I found this old article, I'm not sure it applies but it's all I can think of for the moment https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-7/ee617165(v=ws.10) Power Management for Network Devices in Windows 7 | Microsoft Docs

mluky
Beginner
1,600 Views

as I understand it, the difference in the processor and localization of windows 10.

Thanks for the link.

mluky
Beginner
1,600 Views

Jema, what operating system is installed on your nuc?

jema
Novice
1,600 Views

My os is windows 10 64bit 1703.

mluky
Beginner
1,600 Views

I solved the problem with WOL. Changed Windows settings.

Took advantage of this instruction:

https://windowsreport.com/windows-8-wake-on-lan-problem/ https://windowsreport.com/windows-8-wake-on-lan-problem/

I used:

Solution 1 – Disable Fast Startup feature on your device

and

Solution 7 – Change your power plan settings

At the moment WOL works without problems.

Thank you very much for your help in solving the problem!

PS Attached manual in PDF format so everyone can use it, if the web site will not be available.

jema
Novice
1,600 Views

Good stuff!

I don't remember changing any of those settings. Anyways I'm glad you got it working.

cras1
Beginner
1,600 Views

Had this problem on a few nucs we have. Turned out to be the fast startup setting under the power plan and then -> power button options. Tried everything else, and its crazy that this worked, but here we are. Had all the green internet, power saving settings off, bios is set correctly for wol, deep sleep off etc... all the normal stuff I do, but this i never did before so its awesome that i found this solution!!!

seems like its a known issue going back to at least 2014.

/thread/55903 https://communities.intel.com/thread/55903

/thread/81921 https://communities.intel.com/thread/81921