Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ARina1
Novice
324 Views

enable sleep on NUC10I7FNH2 from command line

Jump to solution

From the start menu, I'm able to put my nuc 10 i7 in sleep mode. Unfortunately, when I run "psshutdown -d" in a window shell with administrator privileges, I get "The local system does not support suspend".

How can I enable it?

Thanks.

 

 

0 Kudos
1 Solution
LeonWaksman
Super User
305 Views

In my NUC10i7FNH I've changed the sleep mode from Modern Standby to Legacy S3 Standby without need to reinstalling the system:

1. Click Windows + R and run msconfig

2. In Boot tab check SAFE boot mode and click Apply. Reboot NUC in SAFE mode.

3. Enter BIOS Power > Secondary Power Settings > Boot Sleep Type change to Legacy S3 standby.

4. Click F10 confirm exit from BIOS and boot into Windows.

5. Run again msconfig and uncheck SAFE boot. Reboot NUC.

Leon

 

View solution in original post

6 Replies
ARina1
Novice
314 Views

Maybe I've used the wrong word. Sleep or suspend? In the Start menu the command has an half-moon icon.

Anyway, I'm referring to the operation that allows the pc to be waked up simply by touching the mouse or the keyboard.

n_scott_pearson
Super User Retired Employee
307 Views

The default in BIOS is to support Modern Standby. If Windows 10 is installed with this setting in the BIOS, then Modern Standby will be supported and you cannot use the psshutdown tool to request Sleep. There is an article here: https://winaero.com/how-to-sleep-windows-10-from-the-command-line/ that shows how to create a script file to to this properly.

If the BIOS has a configuration item that lets you choose S3 (Suspend) support instead (I can't remember if/how the FN NUC's BIOS supported this), installing Windows 10 with this setting in place will support the old Sleep (Suspend) capability.

Hope this helps,

...S

LeonWaksman
Super User
306 Views

In my NUC10i7FNH I've changed the sleep mode from Modern Standby to Legacy S3 Standby without need to reinstalling the system:

1. Click Windows + R and run msconfig

2. In Boot tab check SAFE boot mode and click Apply. Reboot NUC in SAFE mode.

3. Enter BIOS Power > Secondary Power Settings > Boot Sleep Type change to Legacy S3 standby.

4. Click F10 confirm exit from BIOS and boot into Windows.

5. Run again msconfig and uncheck SAFE boot. Reboot NUC.

Leon

 

View solution in original post

ARina1
Novice
283 Views

Thank you. I will follow your instructions after verifing that S0 state cannot be invoked from the command line.

LeonWaksman
Super User
274 Views

Hi @ARina1 

After enabling Legacy S3 standby on NUC10i7FNH I can put it into sleep moed after executing the following commands in Command Prompt (Admin):

powercfg -hibernate off

rundll32.exe powrprof.dll,SetSuspendState 0,1,0

 

Leon

 

ARina1
Novice
286 Views

Thank you.

Unfortunately nothing happens when I run

powercfg -h off
rundll32.exe powrprof.dll,SetSuspendState 0,1,0
Reply