Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,237 Views

nuc8i7hvk booting: "mmc0: Unknown controller version(3)"

Jump to solution

I followed the Intel instructions for updating BIOS to install Linux to my:

  • nuc8i7hvk
  • Crucial CT16G4SFD824A 32GB (16GB x2)
  • Samsung MZ-V7P512BW SSD 970 PRO 512 GB M.2 

 

It re-booted and ran Ubuntu correctly once. But now on second reboot I am getting problems. I now get this during boot.

"mmc0: Unknown controller version(3). You may experience problems."

 

Any suggestions how to proceed. I seem stuck at the moment.

0 Kudos

Accepted Solutions
Highlighted
Super User Retired Employee
560 Views
0 Kudos
11 Replies
Highlighted
Super User
560 Views

Enter Bios settings Advanced > Boot > Secure Boot and verify that Secure Boot is disabled. If enabled uncheck it and press F10, confirmed by "Y" to save settings and exit to O.S.

 

Leon

 

Highlighted
Super User Retired Employee
560 Views

You are using Ubuntu 18.10 or newer, right? I have heard that older versions (16.x) have bugs that can cause issues in UEFI support - like spurious entries in boot table.

...S

Highlighted
Beginner
560 Views

Thanks for the tips! Yes secure boot was disabled.

 

I reverted back to the original 16.04 image and then finally it booted ok without this mmc error, but display colors were reversed on my display via HDMI (any HDMI port).

I finally figured a way to get that back to normal, and I will have to try installing 18.04 again some other day.

 

It's been a bit of a bear trying to install 18.x to this...

 

Thanks!

0 Kudos
Highlighted
Super User Retired Employee
561 Views
0 Kudos
Highlighted
Beginner
560 Views

Wow, super!!! I have been floundering a bit through the instructions it came with, Intel search, ubuntuforums, google search.. with a variety of different posts that were roughly the same but didnt quite work. This looks like exactly what I needed!

0 Kudos
Highlighted
Super User
560 Views

You may try the following:

  1. In Bios - enable the Security Boot and check Clear Secure Boot Data. Press F10 followed by "Y".
  2. Enter Bios again and disable Secure Boot. Press F10 followed by "Y".

 

Leon

 

Highlighted
Beginner
560 Views

I normally stick to Ubuntu LTS, thanks for this 18.10 pointer: great to see this got supported nicely there! If I leave Ubuntu LTS, I may then go to 19.04 to see how well it does.

0 Kudos
Highlighted
Beginner
560 Views

I am giving 19.04 a go...

It is looking good so far...1904.jpg

0 Kudos
Highlighted
Super User Retired Employee
560 Views

If you get it working, respond and let us know. While you are at it, it will help others if you detail the changes in steps necessary to make it work.

...S

0 Kudos
Highlighted
Beginner
560 Views

Intel NUC8i7HVK / Ubuntu 19.04

I do have Ubuntu 19.04 running now. My road there was a bit circuitous.

For completeness, this is what I did:

  • F7 method to install BIOS from a USB stick. I followed: https://ubuntuforums.org/showthread.php?t=2400400
    • I wasn't able to use kernel 4.18 or 4.19 following those steps. There was an un-resolved dependency issue for libssl1.1.
    • I used Kernel 4.15.0 instead
  • Update to Ubuntu 18.04 LTS: From booted / running Ubuntu 16.04 :
    • Change Software & Updates / Updates / Notify me of a new Ubuntu version => For Long-term support versions
    • CLI: 'update-manager -c"
    • Update to Ubuntu 18.04
  • Realize that Ubuntu 18.10 looks golden from this Intel Community thread. Thanks!
  • Update to Ubuntu 19.04: From updated / running Ubuntu 18.04 of last step:
    • Change Software & Updates / Updates / Notify me of a new Ubuntu version => For any new version (instead of LTS)
    • CLI: 'update-manager -c"
    • Update to Ubuntu 19.04

19.04 is working nicely for me so far.

 

I hope this helps some future reader who finds this thread from Googling :).

 

0 Kudos
Highlighted
Beginner
560 Views

I also replaced kernel v4.15.0 with v5.2.8 now and so far so good.

 

Steps using ukuu:

sudo add-apt-repository ppa:teejee2008/ppa

sudo apt update

sudo apt upgrade

sudo apt-get install ukuu-gtk

ukuu-gtk

 

=> install v5.2.8

=> reboot with F2 to make sure "Secure Boot" is disabled, else you may get "kernel xxx has invalid signature" from grub during reboot. I guess upstream versions like this don't have signatures?

 

After reboot: 'uname -a' to check kernel version.

 

It looks excellent now.

 

 

0 Kudos