Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TTihe
Novice
462 Views

[BSOD] DRIVER_POWER_STATE_FAILURE (Issue: 1807642041)

Jump to solution

Hello.

 

My PC is crashing every few hours with BSOD "DRIVER_POWER_STATE_FAILURE".

 

It has something to do with iaStorAC.sys. I tried Optane software 17.0 and 17.5. This bug is mentioned in known issues (1807642041), any ETA on fix?

 

Any workaround?

0 Kudos
1 Solution
TTihe
Novice
211 Views

To clarify further: My Optane is accelerating a secondary drive that is an HDD, while I'm using my NVME for Windows and some other apps. I had 20 min inactive timer on the optane accelerated HDD, after which the HDD turns off (Windows power saving feature).

 

Setting "Turn off hard disk after: Setting (Minutes)" to Never solved the problem. Also I disabled pc sleep states etc. from the power options so my PC and optane HDD is 24/7 in power up state, also when left idle. It's now three days without crashing :)

 

I'll toss a comment here, if I encounter more problems with this BSOD.

View solution in original post

4 Replies
LeonWaksman
Super User
211 Views
  1. Do you have Intel RST Driver installed (SetupRST.exe) or only the Optane Memory Driver(SetupOptaneMemory.exe) ? Any way it should be updated to the latest version. https://downloadcenter.intel.com/download/28966/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf...
  2. In addition update BIOS to the latest version.

 

Leon

 

TTihe
Novice
211 Views

BIOS is the newest one - 7B12v15 (with RST driver 17.2 support), and I have the SetupOptaneMemory.exe installed. Latest version has the same problem.

TTihe
Novice
211 Views

Here's all system specs.

TTihe
Novice
212 Views

To clarify further: My Optane is accelerating a secondary drive that is an HDD, while I'm using my NVME for Windows and some other apps. I had 20 min inactive timer on the optane accelerated HDD, after which the HDD turns off (Windows power saving feature).

 

Setting "Turn off hard disk after: Setting (Minutes)" to Never solved the problem. Also I disabled pc sleep states etc. from the power options so my PC and optane HDD is 24/7 in power up state, also when left idle. It's now three days without crashing :)

 

I'll toss a comment here, if I encounter more problems with this BSOD.

View solution in original post

Reply