Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
327 Views

Enabling my Optane?

Jump to solution
Ok, so I am having trouble enabling my motherboard’s ability to use Intel RST, specifically a 32gb Optane Memory module. To be more precise, I know exactly how to enable RST in my bios, but it then leads to the inability to use my PC, at all. When I enable my ability to use RST, my bios no longer recognizes my SATA drive. As such, I can no longer boot since it is my main drive, but is no longer in the boot list.

So, my question is, how do i enable both RST AND my SATA drives? The other odd thing is that is still recognizes my cd drive even though it is connected via SATA.

I am using an Aorus Z390 Pro WiFi by the way.
0 Kudos

Accepted Solutions
Highlighted
Super User
246 Views

Hi @Jayce86 

1. I suggest you to reinstall Windows using the following method:
2. Please prepare your installation media (you need 8GB – 32GB USB stick), using Microsoft Media Creation Tool. This will install version 2004.
3. Your bios should be set to default settings. UEFI boot should be enabled.
4. With the installation media inserted into rear USB slot, power ON your computer and enter the Boot Menu (I don't know which key you should use, but in many systems it is F10).
5. In this menu, choose UEFI option of you Installation media.
6. Follow this tutorial to continue with installation.
7. In para. 8 you may enter Product Key from the Windows 7 you bought or click on the I don't have a product key and Windows will be reactivated automatically, since it was activated on this computer.
8. Skip on para. 13 and continue in para. 14. Important, do not format drive where you want to install Windows, rather delete all existing partitions from this drive, till you see one unallocated space.
9. Press Next and continue with the installation.

10. The Windows installation will create a Recovery Partition in the end of the system drive. Since for Optane operation you need to prepare 5-15MB of unallocated space in the end of the drive boeing accelerated, please delete the Recovery Partition and and extend the C: partition, leaving 5-15MB of unallocated space.  The system will work perfectly without the Recovery Partition.

Good luck.

Leon



Leon

View solution in original post

0 Kudos
17 Replies
Highlighted
Novice
301 Views

wont boot into windows, because most likely you only have the ahci drivers installed. this driver should work, install first

 

https://downloadcenter.intel.com/download/29647/Intel-Rapid-Storage-Technology-Driver-Installation-S...

0 Kudos
Highlighted
Super User
296 Views

Hi @Jayce86 

1. In order to be able enabling Optane acceleration, the SATA mode in BIOS should be set to "Intel RST Premium with Intel Optane System".

2.  In order to change SATA Mode without destroying Windows boot, Windows must be set to SAFE Boot Mode. While in Windows, press Windows key + r. Run msconfig .  Chose Boot tab and enable Safe boot. Reboot your system.

3. During system boot enter Bios again. Verify in Advanced > Boot that Fast Boot is disabled. If not disable it.

4. Now you can change the SATA mode to "Intel RST Premium with Intel Optane System". Save the setting and boot into windows in SAFE mode. Disregard the warning you will see. 

5. While in Windows, press Windows key + r. Run msconfig. Chose Boot tab and uncheck Safe boot.

6. Reboot your system. Now your system is bootable in "Intel RST Premium with..." mode (however not accelerated). 

7. Open Apps & Features (Windows Settings) and uninstall the currently installed Optane Application. 

8.  Download Intel RST Driver f6flpy-x64.zip and unzip it on your drive. Right click on iaStorAC.inf and select install from drop down menu. Reboot your computer. 

9. Download from Microsoft Store and install the Intel Optane Memory and Management

10. Now enable Optane Acceleration. Follow Intel Optane Memory Installation Guide, Section 3.

Leon

0 Kudos
Highlighted
Beginner
290 Views
Thank you for attempting to help, but your suggestion produced the same results as my previous attempts. I set my pc to boot into safe mode, entered bios, made sure fast boot wasn’t enabled, turned on RST, and did save/exit. Upon my next boot attempt, my SATA drive is mysteriously missing, and I’m stuck in a boot loop since my HDD isn’t detected. The only thing I can think of is to change the SATA port that my HDD is connected to since it only appears that SATA 0 goes missing.
0 Kudos
Highlighted
Beginner
288 Views
I don’t think I was clear enough. It’s not that it won’t boot into windows, it’s that my HDD vanishes from my boot list altogether when I enabled RST. Once i disable RST, all is well again. Minus not being able to use my Optane.
0 Kudos
Highlighted
Super User
282 Views

Hi @Jayce86 

I was not advising you to change the SATA mode to RST, rather to "Intel RST Premium with Intel Optane System". Can you please tell me what are the available SATA mode in your BIOS settings? Please read the minimum hardware requirements and BIOS setting for M Series Optane memory in Intel Optane Memory Installation Guide  Is your system Optane Ready?

Leon

 

0 Kudos
Highlighted
Beginner
277 Views

I was going shorthand by typing RST instead of "Intel RST with Intel Optane System". When I go into advanced I have two options: AHCI and Intel RST with Optane. Changing to the latter completely removes my ability to even use my SATA connected HDD to boot from. Changing back to AHCI restores my ability to use my HDD but prevents the use of my Optane memory. My PC also runs in UEPI, so that's not an issue either. The only two things of i can think of are to either change the current port that my HDD is connected to since SATA 1(my cd drive) continues to be recognized after i switch from AHCI mode, but SATA0(my hdd) does not, or its that my PC uses MBR partitioning from when i upgraded from Windows 7. The downside to option 2 is that I need to fresh install windows to change to gpt.

And yes, according to the box of my Z390 Pro, it is Intel Optane ready, and even has instructions in the book that i cannot follow as i run into "unsupported bios mode intel optane."

0 Kudos
Highlighted
Super User
272 Views

Hi @Jayce86 

1. In BIOS you have to enable UEFI boot (legacy BIOS is not supported by Optane). 

2. The drive partition have to be converted to GPT. The MBR partition is not supported.

3. The good news is that you don't need to reinstalling your system in order to convert partition to GPT type.  This article will guide you how to do this using mbr2gpt utility.

Leon

 

0 Kudos
Highlighted
Beginner
263 Views
I’m going crazy here. I did the convert thing and it said it was successful minus something about recovery not setting up right. I followed the guide, and I’m still using mbr... i just don’t understand.
0 Kudos
Highlighted
Super User
259 Views

Hi @Jayce86 

1. Some times things are not going easy. I'll try to help you.

2. Please open Administrative Command Prompt and run the following commands (click Enter after each command):

  • diskpart
  • list disk

3. Please attach to your post image of the Command Prompt windows after executing the above commands.

Leon

 

 

0 Kudos
Highlighted
Beginner
251 Views
Ok, so I decided to just say screw it, and did a fresh install/reset. I think due to my drive technically being a clone of my old Windows 7 drive, stuff was too messed up to fix. Because when I ran those commands, it said my disk was gpt, but disk management says it’s still mbr. Plus I still couldn’t boot after changing to RST. So, I’m going to reset, and report back to you since you such an amazing person for trying to help my tech illiterate self.

Hopefully this reset puts my disk into the right config so I can just run my Optane memory like I’ve been wanting to.
0 Kudos
Highlighted
Super User
247 Views

Hi @Jayce86 

1. I suggest you to reinstall Windows using the following method:
2. Please prepare your installation media (you need 8GB – 32GB USB stick), using Microsoft Media Creation Tool. This will install version 2004.
3. Your bios should be set to default settings. UEFI boot should be enabled.
4. With the installation media inserted into rear USB slot, power ON your computer and enter the Boot Menu (I don't know which key you should use, but in many systems it is F10).
5. In this menu, choose UEFI option of you Installation media.
6. Follow this tutorial to continue with installation.
7. In para. 8 you may enter Product Key from the Windows 7 you bought or click on the I don't have a product key and Windows will be reactivated automatically, since it was activated on this computer.
8. Skip on para. 13 and continue in para. 14. Important, do not format drive where you want to install Windows, rather delete all existing partitions from this drive, till you see one unallocated space.
9. Press Next and continue with the installation.

10. The Windows installation will create a Recovery Partition in the end of the system drive. Since for Optane operation you need to prepare 5-15MB of unallocated space in the end of the drive boeing accelerated, please delete the Recovery Partition and and extend the C: partition, leaving 5-15MB of unallocated space.  The system will work perfectly without the Recovery Partition.

Good luck.

Leon



Leon

View solution in original post

0 Kudos
Highlighted
Super User
230 Views

Hi @Jayce86 

This post is relevant only if you didn't started the Windows installation yet.  If so, I want suggest that you set the SATA mode in BIOS to "Intel RST Premium with Intel Optane System" before installing Windows. However if you have installed Windows already in SATA AHCI mode, you may change to "Intel RST.." only in SAFE boot mode (as described in my other post).

Leon

 

0 Kudos
Highlighted
Beginner
204 Views
Ok, so I reinstalled Windows, and it has set it self up as GPT with 3 partitions; my C drive, 100mb for efi system, and 527mb for recovery partition. Should i go ahead and delete the recovery partition and add the extra 15mb at the end for my Optane?

Also, one other weird thing; my Optane memory it’s self shows up as disk 0, and is somehow formatted as MBR.
0 Kudos
Highlighted
Super User
184 Views

Hi @Jayce86 

1. Yes, in the last updates Microsoft creates the Recovery Partition in the end of System Drive. Since, you want to accelerate this drive with Optane, you may delete the partition, extend the C: partition, leaving 5-15MB of unallocted space in the drive end.

2. Please attach to your post an image of Disk Management, showing both drives: the System Drive and the Optane memory.

3. Please right click on Windows Start icon and then on Windows PowerShell (Admin). In the PowerShell windows run the following commands (click on Enter after each command):

  • diskpart
  • list disk

Please attach the image of PowerShell windows to your post.

Leon

 

0 Kudos
Highlighted
Beginner
166 Views
All is well good sir, and I thank you for attempting to help. After the fresh air install, I simply put my motherboard’s install disc in, and ran all the programs on there. Then, Optane ran its self without me having to go into Bios.
0 Kudos
Highlighted
Super User
161 Views

Hi @Jayce86 

I'm glad that the Optane works now for you. However, I need  to warn you that if you didn't leave unallocated space in the end of the drive boeing accelerated, the Optane may disable it self.

Leon

 

0 Kudos
Highlighted
Beginner
156 Views
I didn’t really have much time to futz with it last night, but I’ll go home and delete the recovery partition, and insert a new 15mb partition. Then, sometime this weekend, I’m going to be swapping my HDD out for a faster one, so I get to clone my current one, and figure out how to make my Optane work with the new drive!
0 Kudos