Intel® Optane™ Solid State Drives
Support for Issues Related to Solid State Drives based on Intel® Optane™ technology, Intel® MAS and Firmware Update Tool
439 Discussions

Intel SSD Firmware Update Tool won't boot


My old SSD hangs for several seconds reading the SMART log (or so I've been said) on boot and smartctl suggested an update:


Model Family: Intel X18-M/X25-M/X25-V G2 SSDs

Device Model: INTEL SSDSA2M080G2GC

Serial Number: CVPO017103J4080JGN

LU WWN Device Id: 5 001517 95932c119

Firmware Version: 2CV102HD

User Capacity: 80,026,361,856 bytes [80.0 GB]

Sector Size: 512 bytes logical/physical

Rotation Rate: Solid State Device

Device is: In smartctl database [for details use: -P show]

ATA Version is: ATA/ATAPI-7 T13/1532D revision 1

SATA Version is: SATA 2.6, 3.0 Gb/s

==> WARNING: This drive may require a firmware update to

fix possible drive hangs when reading SMART self-test log:

So I followed the link and downloaded the update tool. But it doesn't boot on my system just freezing in the middle. The only option is to reset the PC, Ctrl+Alt+Del or any other keys don't work. The screen background turns green on the freeze (it's black initially). Photo attached, tried to add pci=nocrs to the kernel boot options as it suggests but no change. My goal is to make the system boot faster, now it takes about 5 seconds while detecting devices in AHCI and then another 5 seconds in the Linux kernel before starting systemd. I'd like to eliminate these delays.

My hardware:

Motherboard: Gigabyte Z68A-D3-B3

CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

RAM: 32 Gb

SSD: Intel X18-M/X25-M/X25-V G2 SSDs / SSDSA2M080G2GC



Model Family: Hitachi Deskstar 7K1000.C

Device Model: Hitachi HDS721050CLA362

Serial Number: JP5570HF31KT8P

LU WWN Device Id: 5 000cca 374eafda3

Firmware Version: JP2OA3MA


GPU: GK104 [GeForce GTX 770]

0 Kudos
3 Replies

Hi rkfg,



Thank you for contacting our support community. We understand your situation regarding the Firmware update.



We would like to let you know that he have received similar reports by other users having issues using the Intel® SSD Firmware Update Tool when an NVidia* video card is present in the system. In order for you to be able to use the Intel® SSD Firmware Update Tool, we recommend you to follow the next workaround:



  • issdfut - This is the name of Intel's Linux* binary which updates firmware on SSD devices.
  • Poky - For the sake of this article, Poky is the Linux* image used by Intel® to enable firmware updates using issdfut. Poky is a neat offering from Yocto for a roll-your-own embedded Linux*. Intel® chose well to apply it for booting a firmware update engine.


  • The Poky utility, used in the firmware update tool as of version 2.2.3, fails to graphically render the issdfut user interface when an NVidia® GPU is present, causing Poky to boot to a blank and mostly unresponsive screen, unable to perform SSD firmware updates. If you have a NVidia® GPU the bootable SSD firmware update may not work for you due to NVidia drivers limitations.

Workaround summary:

  • Modify the boot command to include vga=ask for the graphical install option offered at boot. Choose native resolution

Workaround detailed steps:

  1. Burn the Intel® SSD Firmware Update Tool ISO to a CD, or in any other bootable media (USB drive, external drive)
  2. Insert the bootable media in the computer hosting the Intel® SSD
  3. Reboot your computer
  4. When the option to Select kernel options and boot kernel comes up press the TAB key in your keyboard
  5. At the middle of the screen you will see a new message come up, that's the boot command
  6. Modify the boot command to include the following (append): vga=ask
  7. A new message come up, follow the instructions: Press to see video modes available (...)
  8. After pressing Enter you should see the available video modes
  9. Choose the native resolution of your screen. after selecting the resolution the screen will go black for a minute or two. If this worked then you should see the software's End User Agreement.
  10. If it does not work then test using other resolutions

Additional Information (advanced):

  • The boot loader permits interruption with Tab. Press tab at the boot menu, then append linux* 3 to the end of the boot command. This boots to non-graphical runlevel, letting you login to look around.
  • Root has no password and is granted auto-login, but only on tty1.
  • Poky's /etc/inittab is only setup for one getty, but you can add more, enabling them without reboot via init -t1 q
  • Most of the operating system tools (network) are gutted, but you can mount other filesystems while booted to Intel's Poky RAM disk.
  • Even when the tty screen goes dark, it is still responsive.
  • It responds to ctrl-alt-bksp, but the display never comes back to you. Loading Poky's Xorg kills the display, killing Xorg leaves you with a dead display.
  • When Poky, it sets the framebuffer resolution per vga=ask response, and successfully creates the /dev/fb0device. This changes the behavior of the Xorg detection, causing issdfut to load and flash successfully. Without vga=ask, the kernel never creates the framebuffer, and only creates the virtual device fbcon. When Xorgdetects its settings to use and fbcon is the only option, you may lose your screen completely when Xorg starts.

Please let us know the outcome of your situation.



Junior M.
0 Kudos

Thank you for answering. Unfortunately, the proposed solution didn't work for me. After selecting the native resolution (which is 1920x1080x32 for me, tried others with the same result) the screen goes black but the system seems to be completely frozen. I waited for 5 minutes and nothing happened, even NumLock LED doesn't react on NumLock key press. I also tried non-graphical resolutions like 80x25, in that case the outcome is exactly like before, the screen becomes green and everything is frozen, only hard reset works. I also tried adding "linux* 3" (without quotes) to the boot command but it also doesn't work with the exact same result, green background with white text. I suspect the issue is much more fundamental than just setting the framebuffer.

Is it possible to extract the tool from the ISO and run it in the existing Linux environment I use (Debian testing amd64)? I boot Debian from the SSD I want to update so it may not be possible directly, but I have other live USBs that boot fine.

0 Kudos

Hi rkfg,



Thanks for the reply.



We would like to inform you that the Intel® SSD Firmware Update Tool is an OS independent tool so you can not extract it. Since the workaround didn't work for you, we recommend you to use the Intel® Solid State Drive Toolbox, however, this tool only works in Windows* based systems. You will need to connect the SSD directly to the motherboard as a secondary drive.





Junior M.


0 Kudos