Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
16511 Discussions

ALLOW_REGISTER_MERGING supported in Linux Version of Quartus Prime?

SSchm28
Beginner
442 Views

On my workstation i run windows 10 and use Quartus Prime Lite 21.1.0 and all my projects compiles fine.

After setting up CI with a linux VM on an Buildserver one of my projects refuse to compile(Same Quartus version but for linux).

 

I track down the problem and noticed that during Analysis & Synthese process, Quartus Prime on the Linux machine needs a lot more logic.  

During Fitting it doesn't fit into the device (10CL016) and fitting fails.

 

I try to get the same result on the windows machine and i could reproduce the result from the linux machine.

If i set ALLOW_REGISTER_MERGING = OFF i got exactly the same result during Analysis & Synthese and Fitting fails.

So for me it looks like ALLOW_REGISTER_MERGING isn't working or is ignored on the linux machine.

Is that feature not supported ?  or is there a way to force Quartus to enable ALLOW_REGISTER_MERGING?

 

With Quartus Prime lite 20.0 its the same.

 

With best regards,

Sebastian schmitz

 

 

0 Kudos
4 Replies
SyafieqS
Moderator
421 Views

Hi Sebastian,


You can try set the assignment in your qsf and rerun the design and see if this command work. I believe this command support for all OSes that support Quartus included Linux. 


set_global_assignment -name allow_register_merging off


You may refer to link below related to more ALLOW_REGISTER_MERGING

https://www.intel.com/content/www/us/en/docs/programmable/683296/22-1/compilerassignmentsallowregistermerging.html


Anyway, perhaps is it possible to show the syn.rpt or error message?. More info needed here.

And what version of Linux do you use? Make sure to meet the requirement for the OS as link below 


https://www.intel.com/content/www/us/en/support/programmable/support-resources/design-software/os-support.html



0 Kudos
SyafieqS
Moderator
393 Views

May I know if there is any update?


0 Kudos
SyafieqS
Moderator
379 Views

We do not receive any response from you to the previous reply that I have provided, thus I will put this case to close pending. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 


p/s: If any answer from community or Intel support are helpful, please feel free to mark as solution and give Kudos.


0 Kudos
SSchm28
Beginner
336 Views

Sorry for getting back to you so late, i had a few weeks off.

 

I have set the "set_global_assignment -name ALLOW_REGISTER_MERGING OFF" in the qsf projectfile to reproduce the problem on the Windows machine.

Then i set ALLOW_REGISTER_MERGING ON in the qsf file to avoid that quartus maybe take some default values from the assignments_defaults.qsf, but that doesn't changed anything.

 

Regarding the link to the documentation. Is that correct that ALLOW_REGISTER_MERGING  is only supported on Arria 10 and Cyclone 10 GX? The project is with an Cyclone 10 LP,  nevertheless that feature works on the Windows version of Quartus for Cyclone 10 LP.

 

I run Quartus on an Ubuntu 18.04 , that shows up on the list of supported Linux distributions.

 

What report do you mean?

I have cmp, flow, fit, asm, sta and map report but no syn.

0 Kudos
Reply