Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14953 Discussions

Bugs in Q20.1 Vector Waveform Editor and Modelsim simulation.

BrianHG
New Contributor I
264 Views

Hello,

I just upgraded from Q18.1 to 20.1.  I found 2 bugs with opening or generating a new .vwf (vector waveform file) and running a functional or timing simulation.

1.  When creating a 'New University Program VWF' and adding the IO pins and clock, If I save as with a file name anything other than 'Waveform.vwf', I get an error message:

Error (199014): Vector source file C:/altera/Qdesigns/HDMI_480p_1KHz_Sine/Waveform1.vwf specified with --testbench_vector_input_file option does not exist

Error: Quartus Prime EDA Netlist Writer was unsuccessful. 1 error, 0 warnings

Error: Peak virtual memory: 495 megabytes

Error: Processing ended: Sat Jan 09 21:00:35 2021

Error: Elapsed time: 00:00:01

Error: Total CPU time (on all processors): 00:00:01

 

Error.

 

2.  Now, when I do save the file name as 'Waveform.vwf', I get this new error:

# vsim -novopt -c -t 1ps -L cycloneive_ver -L altera_ver -L altera_mf_ver -L 220model_ver -L sgate_ver -L altera_lnsim_ver work.HDMI_test_vlg_vec_tst

# Start time: 21:03:23 on Jan 09,2021

# ** Error (suppressible): (vsim-12110) The -novopt option has no effect on this product. -novopt option is now deprecated and will be removed in future releases.

# Error loading design

Error loading design

 

# End time: 21:03:23 on Jan 09,2021, Elapsed time: 0:00:00

# Errors: 1, Warnings: 0

 

This used to work fine in Quartus Prime Lite 18.1.

Other than downgrading, is there a fix?

 

0 Kudos
1 Solution
SyafieqS_Intel
Moderator
249 Views

Hi Brian,


Remove the novopt command in your script and resimulate.


View solution in original post

2 Replies
BrianHG
New Contributor I
263 Views

Ok, found a solution.  I just need to remove the -novopt option every time in the simulator setting as Quartus keeps on inserting it in new projects.

SyafieqS_Intel
Moderator
250 Views

Hi Brian,


Remove the novopt command in your script and resimulate.


View solution in original post

Reply