Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14943 Discussions

Couldn't configure FPGA with rbf file through uboot loader

Zafar_Ali
Beginner
197 Views

I was trying to configure the FPGA in DE-10 nano with an rbf file converted from an sof file using Quartus 18.1. But I was not able to configure FPGA with rbf file through uboot loader although I had been able to configure the fpga with the same sof file through jtag.

I wasn't able to figure out why its not working. should I play around with the conversion settings? Is there any way to check the validity  of the rbf file?   

0 Kudos
1 Solution
YuanLi_S_Intel
Employee
162 Views

Hi Zafar,


CONF_DONE LED is not turning on means configuration failure. It might be due to RBF, uboot and host.


Can you try to program the RBF file without adding any extra logic on it? Just would like to make sure if your HPS side is correct or not.


Thank You


View solution in original post

3 Replies
YuanLi_S_Intel
Employee
183 Views

Hi Zafar,


Is there any error message when programming failure? or have you probed the configuration pin such as CONF_DONE, INIT_DONE, nCONFIG and nSTATUS?


Also, during RBF file generation, have you selected the correct flash memory used to store?


Mind if i ask you, from where you following the guide to use uboot?


Thank You.


Regards,

bruce


Zafar_Ali
Beginner
180 Views

Hi Bruce,

There wasn't any programming errors. I haven't probed the configuration pins. I just observe the CONC_D led on my DE_10 nano board.

I followed the following terasic tutorial for rbf conversion settings and as uboot guide:

https://github.com/intel-iot-devkit/terasic-de10-nano-kit/releases/tag/tutorials-v1.0.0

Apart from the tutorials I only tried to add a custom IP in the Qsys system with an Avalon slave interface which works fine when I configure the fpga via jtag.

It works with the blink.rbf given in the tutorial.

 

Thank you 

YuanLi_S_Intel
Employee
163 Views

Hi Zafar,


CONF_DONE LED is not turning on means configuration failure. It might be due to RBF, uboot and host.


Can you try to program the RBF file without adding any extra logic on it? Just would like to make sure if your HPS side is correct or not.


Thank You


View solution in original post

Reply