Community
cancel
Showing results for 
Search instead for 
Did you mean: 
GK4
Beginner
524 Views

DSE - How to setup remote server with SSH

I am trying to setup a PC as remote farm for DSE compilations.

Currently I am getting the following:

Warning: [Errno 11001] getaddrinfo failed Error: [Errno 11001] getaddrinfo failed Error: Traceback (most recent call last): File "server.py", line 103, in run_impl File "f:\intelfpga\18.1\quartus\common\python\lib\socketserver.py", line 430, in __init__ self.server_bind() File "f:\intelfpga\18.1\quartus\common\python\lib\socketserver.py", line 441, in server_bind self.socket.bind(self.server_address) socket.gaierror: [Errno 11001] getaddrinfo failed

Settings Client side (Windows 10 - Quartus 18.1):

I tried all settings, where there is a reference to the remote PC with the IP address and hostname and tried all possible combinations.

The IP address looks like no LAN IP address, but it is a LAN IP address - Network: 192.9.200.0/24 the remote and local PC are in the same sub.

  • Hostnames: Chattanooga-PC
  • Quartus Root Path: C:\intelFPGA\18.1\quartus - tried with \\ and // at the beginning - This is the quartus folder on the remote PC
  • SSH Client: made different attempts to use plink, with full path, with .exe and without any synthax
  • Farm Operating System: windows
  • Local to Remote Path Mapping: [Local path];[Shared Folder] - where [Shared Folder] is accessable from my local PC - with and without // at the beginning
  • initial Working Directory: [Shared Folder]

 

Settings remote PC Windows 10 Quartus 18.1 with Trial license

  • OpenSSH Server with optional Windows Features enabled
  • SSH connection from local to remote PC is possible with putty

 

 

* Additional comment: I read some entries which mentioned the setup video: I got the same feeling, there is SSH mentioned but there is nowhere enough information to SSH in the video and it would be nice to know if it's even possible to use windows with LSF or how to test the cygwin ssh commands.

 

Also the Post editor in this forum is not to my liking. You click one time in the wrong place and the whole question is lost and the editor window is too small.

0 Kudos
10 Replies
207 Views

Hi,

 

Can you follow the steps in How to setup Remote farm machine in Design Space Explorer II video published by Intel FPGA and let me know at which stage you see the error?

https://www.youtube.com/watch?v=WdO5VOQkl7s

 

Please let me know if you have any questions.

 

Thanks.

 

 

207 Views

Hi,

 

Can you try setting the Host value to "127.0.0.1" from within the DSE Server Settings section of the Exploration tab in the DSE II GUI?

 

Thanks.

GK4
Beginner
207 Views

Hello,

What I haven't done: Using keys for the SSH connection.

I have to wait for the IT to configure the SSH keys.

For the 127.0.0.1 setting, I put in: Exploration => Registartion Host = 127.0.0.1 Registration Port = 0 on the client PC.

Same result.

Is there anything else I can try in the meantime?

207 Views

Hi,

 

Have you tried to set this in the .dse file?

 

Thanks

GK4
Beginner
207 Views

Hello,

 

We tried some SSH settings on the remote Windows host, still no success.

Currently we are setting up a Linux machine, but this will be done next week.

 

Can you clarify where i have to set this in the .dse file?

207 Views

Hi,

 

You can add the following in the .dse file

 

host=127.0.0.1

 

Thanks.

GK4
Beginner
207 Views

Ok, after various tries, we stopped trying to get the DSE running and resorted to manually archive the project and extract it on the remote host.

Adding the host=127.0.0.1 line resulted in a different error message:

Failed to connect to [remote host]. If private key is encrypted, please run ssh key agent first

I tried different client software fro connecting to the host with the private key i gave the DSE client and all were successfull.

I added the path: \\C:\Users\[Local user]\.ssh\id_rsa , same result with: ~/.ssh/id_rsa - Then i switched the \ to a / and i got the error:

Unable to open connection, host does not exist. Tried with hostname and IP Address.

 

207 Views

Hi,

 

Can you try

1) run 

 plink -i fpgauser.ppk -l root <remote host> -P <port>

first and accept the host's fingerprint.

2) After confirming the fingerprint, rerun:

plink -i fpgauser.ppk -l root <remote host> -P <port>

Confirm that you can connect to remote host without being prompted about password and without prompted to accept host fingerprint or any other prompts. Plink should directly go to the remote host's prompt. If there any other prompts, please let us know. If you can confirm there are no further prompts, try the same host using DSE.  

 

Thanks.

207 Views

Hi,

 

Do you have any updates?

 

Thanks

GK4
Beginner
207 Views

Hello,

 

We stopped trying to get it running.

Reply