Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15477 Discussions

DSP Builder MegaCore Import Error

ThangND
Beginner
419 Views

I'm creating a block in DSP Builder using the MegaCore Import in the library. After instantiating the block with all the necessary parameters in Qsys, I've generated HDL file and then return to DSP Builder so that my block is generated in this software. However, I've received an error notification as follows:

megacore import error.png 

This is my first time seeing this error. Could anybody help me with this ? 

0 Kudos
6 Replies
CheePin_C_Intel
Employee
405 Views

Hi,


As I understand it, you encounter some problem with the megacore import. By merely looking at the error message, it seems to say that the target directory that you are importing is no accessible. One of the possibility is due to the write permission to that directory. Would you mind to share with me you files, detailed steps to import and DSP builder version that you are using? I would like to try performing problem replication on my side if I have the right DSP Builder version. Thank you.


ThangND
Beginner
398 Views

Hi, 

 

I'm using Quartus version 16.1 and Matlab R2018a. As you can see, I'm having trouble with the megacore functions in DSP Builder. For example, I'm using the FFT Megacore Functions to generate the IP, but there are still the errors: 

fft generate fail.png

I've already run the command "alt_dspbuilder_setup_megacore" as suggested in the DSP Builder Handbook for installing the megacore functions. Did you have any problems with using the megacore functions like that ever before ? Let me know if you have any ideas to fix this error. Thank you. 

 

CheePin_C_Intel
Employee
386 Views

Hi,


Sorry for the delay. As I look into the latest DSP Builder Advanced handbook, it seems like I am unable to locate the alt_dspbuilder_setup_megacore. From the latest handbook, the HDL import is using HDL Import Configuration and HDL Import blocks. Can you install the latest DSP Builder version and check out the "DSP Builder HDL Import Design Example" in the handbook. When you open up the hdl_import_duc.mdl, you will see detailed step by step guiding how to import HDL into the example design.


Please let me know if there is any concern. Thank you.


ThangND
Beginner
375 Views

Hi,

Thanks for your support. My problem was resolved a few days ago by reinstalling the software with some additional devices. 

CheePin_C_Intel
Employee
374 Views

Hi,


Thanks for your update. Glad to hear that you have managed to resolve it. Thank you.


CheePin_C_Intel
Employee
374 Views

I believe the initial inquiry has been addressed. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply