Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,145 Views

Error: Can't launch ModelSim-Altera Simulation software

Hi, 

 

I am using quartus web edition and ModelSim-Altera starter under ubuntu 12.04 (32-bit) system. 

 

However, after compling, when I execute simulation, I got one error: 

Nativelink TCL script failed with errorInfo: Can't launch ModelSim-Altera Simulation software -- make sure the software is properly installed and the environment variable LM_LICENSE_FILE or MGLS_LICENSE_FILE points to the correct license file. 

 

In my PC, I installed another Mentor product, which will use LM_LICENSE_FILE or MGLS_LICENSE_FILE. 

 

Is this issue because: when I installing quartusii+modelsim-altera-starter, the installer detected this system has "Flexible License Manager" lmgrd, and then my modelsim-altera-starter beame the subscriber version? 

 

Please help me to fix it.
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
308 Views

Problem was solved. 

 

I deleted ".altera" folder, which is under the home directory. 

 

Then, I run the program, and it works.
Altera_Forum
Honored Contributor I
308 Views

I know that this is a somewhat old thread ... but I would like to put my two cents as others may benefit from my solution. I did removed the .altera_quartus hidden directory, and I still had issues with it. However, I went a bit further and then deleted the .modelsim file ... and that did it. Issue went away. Please note that these are hidden files and thus the "."(dot) is in front of the name.

Altera_Forum
Honored Contributor I
308 Views

Hi, I am with the same problem. However, I deleted altera_quartus but it does not work and i did not see any folder named as .altera or .modelsim. Need some suggestion

RZhen11
New Contributor I
266 Views

Unfortunately, I ran into this with ubuntu 16.04 LTS

modelsim-altera FPGA Edition (16.1).

Starter edition works fine.

I'm 100% positive $LM_LICENSE_FILE is set properly.

Reply