Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16653 Discussions

Error occured when downloading .sof into device

Shark121
Novice
1,811 Views

We use Quartus 20.2 programmer to download a .sof file to device(1SX280LN3F43E2VG), by JTAG(usb-blaster), and meet the problem below:

 

Error (18950): Device has stopped receiving configuration data

Error (18948): Error message received from device: Detected bitstream error. Please make sure that the bitstream is compatible with the current Quartus version and device version. (Subcode 0x0040, Info 0x00000003, Location 0x0000A800)

Error (209012): Operation failed

 

The .sof file is generated by Quartus Prime Pro 20.2

I would like to know what happened and how to fix it, thank you!

0 Kudos
1 Solution
NurAiman_M_Intel
Employee
1,792 Views

Hi,


Thank you for contacting Intel community.


  1. You can check the error and workaround for Quartus Pro 20.2 in the link below:

https://www.intel.com/content/www/us/en/programmable/quartushelp/20.2/index.htm#quartus/gl_quartus_welcome.htm


2.On top of that, please try to use latest version of Quartus Pro. Users should upgrade to the latest version of the Quartus.

https://fpgasoftware.intel.com/20.2/?edition=pro&platform=windows


Let me know if you need further information.


Regards,

Aiman


View solution in original post

0 Kudos
3 Replies
NurAiman_M_Intel
Employee
1,793 Views

Hi,


Thank you for contacting Intel community.


  1. You can check the error and workaround for Quartus Pro 20.2 in the link below:

https://www.intel.com/content/www/us/en/programmable/quartushelp/20.2/index.htm#quartus/gl_quartus_welcome.htm


2.On top of that, please try to use latest version of Quartus Pro. Users should upgrade to the latest version of the Quartus.

https://fpgasoftware.intel.com/20.2/?edition=pro&platform=windows


Let me know if you need further information.


Regards,

Aiman


0 Kudos
Shark121
Novice
1,778 Views

Thank you for your answer!

Problem solved, the reason is input clock mismatched.

I change the configuration clock source(in "device and pin options") from 125MHz to internal or 25MHz, then it works. And I checked the schematic diagram, it's a 25MHz oscillator connected to OSC_CLK_1 pin

0 Kudos
NurAiman_M_Intel
Employee
1,767 Views

Hi,


Great to know that your issue is solved. I will proceed to close this case, however, if you need further support, you may open a new case in the future.


Thanks.


Regards,

Aiman


0 Kudos
Reply