Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15475 Discussions

How to resolve a libpng12.so.0 error on CentOS System?

Prachi_S_Intel
Employee
1,543 Views

When I am trying to install Intel FPGA SDK for OpenCL, I am getting an error as "quartus: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory" for CentOS Linux 7 (Core). I applied the solution listed on the forum, but it did not work for me. Could someone help me with this?

 

0 Kudos
3 Replies
HRZ
Valued Contributor II
1,008 Views

Do you get this error while installing the SDK or using it? If this is during installation, can you post the command you run that generates the error? If this is during usage, can you post the environmental variables that you have set in your .bashrc to get OpenCL to work? You can install that missing library by running "sudo yum install libpng12". However, this should not be normally required unless you are using an old version of Quartus. Please also post the version of Quartus you are using and your board model.

Prachi_S_Intel
Employee
1,008 Views

I am getting the error while trying to install Intel FPGA SDK for OpenCL(AOCL-pro-18.1.0.222-linux). The CentOS version that I am using is CentOS Linux release 7.5.1804 (Core). I get the error "quartus: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory" when I run command "./setup_pro.sh" which is provided to install the tool. Please let me know.

HRZ
Valued Contributor II
1,008 Views

I just checked my own environment, I indeed have "libpng12" installed. Please try installing it using the command I mentioned in my previous reply and see if it solves the problem.

Reply