Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15323 Discussions

MAX10 .sof and .pof programming problem - device remains tristate

Ivor
Beginner
175 Views

First time using MAX10.

I have  three LEDs connected, VHDL driving one low, one high and toggle third one.

  1. I do compile, .sof is generated. Run programmer and autodetect.
  2. Device is selected correctly as per hardware
  3. I program .sof with JTAG and it show successful, but LEDs remain in tristate

So I tried the autogenerated .pof file, but it just fails programming to CFM0 ( single image)

  1. to do this, I delete the .sof line in programmer and add the .pof file, it then shows the CFM0 and UFM.
  2. I tick the CFM0 for programming
  3. and click on start

 

DEV-OE pin is connected to GND

DEV-CLRn is floating

CONFIG_SEL = '1'

nConfig pulled to '1'

CONF_DONE and nSTATUS t oground via LED+resistor

 

In device pin options the following settings:

  1. no tickboxes enabled
  2. internal configuration
  3. single compressed image
  4. tickbox for "generate compressed bitstream" enabled

Any ideas welcome..

0 Kudos
3 Replies
YuanLi_S_Intel
Employee
157 Views

Can you share me what is the error message you get when you are programming POF using quartus programmer?


Meanwhile for the SOF file, can you check if your LED is connecting to the correct pin in the VHDL? It should work once SOF file is able to program into it.


Ivor
Beginner
156 Views

Actually, I have just sorted out the problem.

Both the nStatus and CONF_DONE lines were just going to GND via resistor and LED. So I pulled them up to Vcc via 10k and then after SOF programming, the device came out of tristate and the POF programming then also worked.

 

Thanks for the reponse though.

 

My next issue is that the elf download fails due to not being able to pause or reset NIOS. Is there a simple example design to use to check that it is not some other hardware problem?

YuanLi_S_Intel
Employee
152 Views

Hi,


We have several design example for NIOS II on MAX 10. You may take a look at link below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/tt/tt_my_first_nios_sw.pdf

https://www.intel.com/content/dam/altera-www/global/en_US/uploads/4/4f/Hello_world_LCD_tutorial.pdf


You may find more design example at link below:

https://fpgacloud.intel.com/devstore/


If you have further question on NIOS, i would suggest you to create another thread in NIOS II category so that our NIOS expert in the community is able to assist.


Regards,

Bruce


Reply