Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15322 Discussions

FPGA Download Cable Driver Not working

Dde_B
Beginner
205 Views

Hi All,

So yesterday both of my old Altera Blaster programmers were found to no longer work. They work on an older machine no problem. 

  • Device Manager reports code 39 that there is a problem with the driver.
  • research suggested this is a driver signing issue so I followed instructions to boot with driver signing disabled still not working.
  • I then booted up into Safe mode, installed driver by pointing to the relevant folder in the IntelFPGA directory. This time no yellow triangle. Driver works and is installed.
  • Boot back into Windows normally, little yellow triangle is back in device manager and it no longer works.
  • Thinking it may be a clash with other drivers on my machine (last chance saloon now), I re-installed windows. Still not working.

This has happened only very recently, like in the last couple of months at the longest as I was using it March/April with no issues.

 

I am using v18.1 of Quartus because of the stupid NIOS bugs in later version that prevent the NIOS EDS tools working properly. And I have even tried using an older version of the drivers from the installing v16.1 of the standalone programmer.

Can anybody offer a solution please I am desperate right now, I have a hugely important project to work on and nothing I try is working.

 

I used to trust Altera stuff, it seems the tools are getting flakier and the support is falling away. 

0 Kudos
3 Replies
JohnT_Intel
Employee
169 Views

Hi,


I would recommend you to download Quartus 21.1 version of standalone Programmer in order to get the latest driver which will fixed the issue.

You may I also refer to https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base... for more information


deBoogle
Beginner
146 Views

Thank you so much this worked a treat. At first, I didn't think it had, then I tried again and the driver went in.

JohnT_Intel
Employee
146 Views

Glad to be able to help.


Reply