Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,014 Views

Programmer: Add new CFI Flash Device doesn't work

Hi there, 

 

I wanted to add a custom Flash device in Programmer (which is listed as compatible (https://www.altera.com/support/support-resources/supported-flash-devices-for-cyclone-v-and-arria-v-s...)). So I use right mouse click -> edit -> define cfi flash device and can't find my device in the list (which doesn't surprise in the first place). 

https://www.alteraforum.com/forum/attachment.php?attachmentid=15153  

 

So I use the [New] button, fill in my parameters: 

https://www.alteraforum.com/forum/attachment.php?attachmentid=15154  

(By the way: What's extended device ID? I can't find it in datasheet (https://www.mouser.de/datasheet/2/100/001-98283_s25fl128s_s25fl256s_128_mbit_16_mbyte_25-775474.pdf)) 

 

Then I click [OK] aaaand... come back to the first window with nothing changed. 

 

What am I doing wrong? 

 

Thanks in advance.
0 Kudos
3 Replies
Highlighted
Valued Contributor III
10 Views

Can someone help here, or am I really doing an exotic thing nobody else does?

0 Kudos
Highlighted
Beginner
10 Views

I've got the same issue. Did you ever resolve it?

0 Kudos
Highlighted
Partner
10 Views

If you run Quartus as Adminitrator it should all work well. i.e.:

 

Note: User flash-defined information is stored in the Windows registry. Therefore, you must have the system administration (administrator) privileges in order to store the parameter in the Define New Flash Device window in the Intel® Quartus® Prime programmer.

0 Kudos