Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DrewBaden
Beginner
455 Views

Quartus 2 and Modelsim-Altera problem on Windows 10

When I run Modelsim-Altera from inside Quartus 2, after Elaboration, Synthesis, etc, it fails inside Modelsim-Altera and complains that rtl_work is empty. And sure enough, it is. The .do file that creates the directory is created when Modelsim starts up. Here's the output from the Modelsim-Altera transcript, below. Apparently what does is first delete rtl_work if it's already there, then vlib specifies that rtl_work will be the library directory, and then vmap maps its "work" directory to rtl_work. the program vlog then builds it. At least, that's my understanding. But the problem is that the command

 

vmap work rtl_work

 

doesn't work. It doesn't happen. So vlog cannot find it.

 

I don't know how vmap works, but I have feeling this is a windows 10 problem, since this worked ok when I was using windows 7.

 

Any help?

 

# Reading D:/Altera/13.1/modelsim_ase/tcl/vsim/pref.tcl 

# do top_run_msim_rtl_verilog.do 

# if {[file exists rtl_work]} {

# vdel -lib rtl_work -all

# }

# vlib rtl_work

# vmap work rtl_work

# Copying D:\Altera\13.1\modelsim_ase\win32aloem/../modelsim.ini to modelsim.ini

# Modifying modelsim.ini

# ** Warning: Copied D:\Altera\13.1\modelsim_ase\win32aloem/../modelsim.ini to modelsim.ini.

#     Updated modelsim.ini.

# vlog -vlog01compat -work work +incdir+C:/Users/drew/rpi_de3_vC {C:/Users/drew/rpi_de3_vC/uart_tx.v}

# Model Technology ModelSim ALTERA vlog 10.1d Compiler 2012.11 Nov 2 2012

# ** Error: (vlog-19) Failed to access library 'work' at "work".

# No such file or directory. (errno = ENOENT)

# ** Error: D:/Altera/13.1/modelsim_ase/win32aloem/vlog failed.

# Error in macro ./top_run_msim_rtl_verilog.do line 8

# D:/Altera/13.1/modelsim_ase/win32aloem/vlog failed.

#  while executing

# "vlog -vlog01compat -work work +incdir+C:/Users/drew/rpi_de3_vC {C:/Users/drew/rpi_de3_vC/uart_tx.v}"

 

 

0 Kudos
1 Reply
DrewBaden
Beginner
108 Views

I think I found the problem. At least, I found a workaround. It might be a windows 10 issue. What I had to do is right click on the C drive, and change all the permissions to "Full Control". Then log out and log back in. Seems to work.

Reply