Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
948 Views

Symbol insertion into Block Design file issue

Hi, 

 

I'm learning how to design a cpu controlled system using niosII platform with Quartus version 6.1g. I've followed exactly the instructions on how to do that. The problem I'm having is when comes the rime to insert the sysmbol into the Block Design file. When I try to place the symbol into the block, I get the following error message : 

 

Can't insert Symbol into Block Design File filename because the Symbol represents the current Block Design File 

 

I figured that it's basically saying that it can't install itself on top of itself. At first, I thought it was because I chose to give the Symbol and the Block File the same name. I restarted the whole process from scratch but this time I named the Symbol and The Block File differently; but I still get the same error message. 

 

Does anybody have came across that problem and can it be solved?. I tried to do the same thing with QUARTUS II version 7.0 and I did not have this error message except I was not able to run the IDE Platform. 

 

Thanks for the help. 

 

Regards,
0 Kudos
1 Reply
Highlighted
Valued Contributor III
22 Views

Don't worry looking further. I found the problem. Make sure not to use duplicate block and symbol names; at least with QuartusII version 6.1g.

0 Kudos