Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
900 Views

USB Blaster failed to program on Lubuntu17.10

I've just upgraded my system from Lubuntu15.10 to Lubuntu17.10 on my laptop. But the USB blaster failed to work. 

Device recognization is OK, programming seems to work, but finally nothing was downloaded to the FPGA. 

 

If I use Windows XP in VirtualBox on my laptop, the USB Blaster works fine.So I'm now running a jtag server on Xp and connect programmer to it through bridged virtual local network. What could be the problem? 

 

Below is done: 

sudo mount --bind /dev/bus /proc/bus 

sudo ln -s /sys/kernel/debug/usb/devices /proc/bus/usb/devices 

 

And udev rules is added: 

SUBSYSTEM=="usb", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6001", MODE="0666" 

 

Quartus version is 13.1 linux64.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
66 Views

Hi, 

 

Is there any error message? 

can you attach the dmesg & commands? 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
66 Views

On the USB enumerate period, there're nothing abnormal. 

 

[2009144.034482] usb 1-1.2.4: reap 0000000000000000 

[2009376.951550] usb 1-1.2.4: USB disconnect, device number 116 

[2009384.361494] usb 1-1.2.4: new full-speed USB device number 117 using xhci_hcd 

[2009384.486569] usb 1-1.2.4: New USB device found, idVendor=09fb, idProduct=6001 

[2009384.486575] usb 1-1.2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 

[2009384.486578] usb 1-1.2.4: Product: USB-Blaster 

[2009384.486581] usb 1-1.2.4: Manufacturer: Altera 

[2009384.486583] usb 1-1.2.4: SerialNumber: 91d28408 

 

The virtualbox's windowsXP quartus is also working on this device
Reply