Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
15800 Discussions

Update Cyclone III to Cyclone 10

hueslei
Beginner
240 Views

Hi, 

 

I need update my Cyclone II to Cyclone 10, but when I try compile the code, Quartus return error message below:

 

" Error (292019): IP core Nios II Processor (6AF7_00A2) not supported in device family Cyclone 10 LP. Choose a new device family or upgrade your IP core to a newer version. The Intel FPGA Knowledge Database contains many articles with specific details on how to resolve this error. Visit the Knowledge Database at https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/kdb-fi... and search for this specific error message number.
Error (292019): IP core Nios II Processor (6AF7_00A2) not supported in device family Cyclone 10 LP. Choose a new device family or upgrade your IP core to a newer version. The Intel FPGA Knowledge Database contains many articles with specific details on how to resolve this error. Visit the Knowledge Database at https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/kdb-fi... and search for this specific error message number. "

I use Quartus II 7.2sp3 with valide license. 

To update I started using  Quartus Prime Lite Edition 20.1.

I need a new license to be able compile the code or is it a bug of Quartus Prime?

 

 

 

 

0 Kudos
7 Replies
jozephka99
New Contributor II
231 Views

If you use Cyclone 10 LP device you can use Quartus Prime Lite, if you use other Cyclone 10 models you cannot use Lite edition and you must have new license for paid editions.

hueslei
Beginner
228 Views

I intend use Cyclone 10 LP with Quartus PRime Lite version 20.1 and I tested right now the version 18.1. The same error occur.

 

 

 

ak6dn
Valued Contributor III
220 Views

The error message is pretty obvious and explicit. Your existing project on the Cyclone II uses a specific Nios II processor IP core.

In the new device you select, the Cyclone 10 LP, that Nios II processor core you are using is NOT supported.

So you can't just change the device family, change the Quartus version, and recompile your existing design.

You have to replace the Nios II core with a supported/updated Nios II core on your new device (Cyclone 10 LP).

hueslei
Beginner
216 Views
Maybe it's obvius to you!!
I asked it because I know others example they performed procedure exactly like me and the project compile without problems.
Anyway, thanks for your comment.
ak6dn
Valued Contributor III
208 Views

Well:  "IP core Nios II Processor (6AF7_00A2) not supported in device family Cyclone 10 LP. Choose a new device family or upgrade your IP core to a newer version." is pretty straightforward.

 

It is not uncommon at all to have to upgrade your IP module to a newer version if you move to a newer version of Quartus (moving from v7.2 to v20.1 is a significant change), and especially if you change the device family. You are doing both.

EricMunYew_C_Intel
Moderator
200 Views

You will need to create a new Nios II from beginning, and not to copy the old Nios design.


EricMunYew_C_Intel
Moderator
188 Views

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply