Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16697 Discussions

Waveform simulation vopt error

frank2597
Novice
1,743 Views

Hello i just recently installed the Quartus Prime Lite edition version 22.1.1 and i am trying to use the waveform editor. When i try to run the simulation i get the following error:

 

 

 Error (suppressible): (vsim-12110) All optimizations are disabled because the -novopt option is in effect. This will cause your simulation to run very slowly. If you are using this switch to preserve visibility for Debug or PLI features, please see the User's Manual section on Preserving Object Visibility with vopt. -novopt option is now deprecated and will be removed in future releases.
# Error loading design

 

I am using the default settings:

 

vsim -novopt -c -t 1ps -L cyclonev_ver -L altera_ver -L altera_mf_ver -L 220model_ver -L sgate_ver -L altera_lnsim_ver work.and_block_vlg_vec_tst

 

changing -novopt to -vopt removes the error but the simulation outputs doesn't seem to make sense, for example a simple AND block with both inputs set to 1 produces a constant 0 

Can anyone help me resolve this? Thank you

0 Kudos
1 Solution
frank2597
Novice
1,655 Views

Hello,

 

I was able to fix this problem by  going into the simulation settings and add -suppress 12110 to the following line:

vsim -suppress 12110 -novopt -c 

I also had to give full write permissions(Full control to modify in folder properties) to folder C:\intelFPGA_lite\22.1std\questa_fse\intel\verilog\cyclonev

 

After these two steps the error no longer appeared 

View solution in original post

0 Kudos
4 Replies
Nurina
Employee
1,709 Views

Hello,


Can you share your design?


Thanks,

Nurina


0 Kudos
Nurina
Employee
1,676 Views

Hello,


Can you provide some updates?


Thanks,

Nurina


0 Kudos
frank2597
Novice
1,656 Views

Hello,

 

I was able to fix this problem by  going into the simulation settings and add -suppress 12110 to the following line:

vsim -suppress 12110 -novopt -c 

I also had to give full write permissions(Full control to modify in folder properties) to folder C:\intelFPGA_lite\22.1std\questa_fse\intel\verilog\cyclonev

 

After these two steps the error no longer appeared 

0 Kudos
Nurina
Employee
1,637 Views

Hello,


I’m glad that your problem has been solved, I now transition this thread to community support. If you have a new question, please login to https://supporttickets.intel.com , view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.


p/s: If any answer from community or Intel support are helpful, please feel free to mark as solution, give Kudos and rate 4/5 survey


Regards,

Nurina


0 Kudos
Reply