Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15463 Discussions

Where to set board library dependency on linux?

Altera_Forum
Honored Contributor II
1,112 Views

It's killing me to try to run this on Ubuntu... 

With Ubuntu 16.04.03 kernel 4.7, I finally got the board to install, aocl diagnose all good, jtagconfig have some trouble but resolved, compile example code .aocx file no problem,  

and now, it's loading the wrong board mmd..... 

Initializing OpenCL Error: Could not load board library /home/matthew/intelFPGA/17.0/hld/board/c5gt/linux64/lib/libaltera_c5gt_mmd.so  

Not sure why it's loading from 17.0 which I removed and replaced with 17.1 pro. 

PATH: /home/matthew/intelFPGA_pro/17.1/quartus/bin:/home/matthew/intelFPGA_pro/17.1/hld/linux64/bin:/home/matthew/intelFPGA_pro/17.1/hld/bin:/home/matthew/intelFPGA_pro/17.1/qsys/bin:... 

LD_LIBRARY_PATH: /home/matthew/intelFPGA_pro/17.1/hld/host/linux64/lib:/home/matthew/intelFPGA_pro/17.1/hld/board/a10_ref/linux64/lib 

 

The section "Linking to the ICD Loader Library on Linux" in the programming guide said: modify theMakefile, 

but it's not clear what to modify and I don't have a clue. On windows10 I just set the registry key and it work right away... 

 

Probably a simple path setting can fix this but I just can't find it:evil: 

Any help is appreciated! 

 

 

---------------------------------------- 

Might as well talk about how to get this thing working on Ubuntu 16.04: 

Kernel 4.13 won't work so I install 4.4, it can install board driver but there's other issue(internet) so I switch to 4.7. 

Jtag usb device can't be detected (shows up in lsusb but can't find device with jtagconfig) 

Use the following command to correct it: 

$ sudo killall -9 jtagd $ sudo mount --bind /dev/bus /proc/bus $ sudo ln -s /sys/kernel/debug/usb/devices /proc/bus/usb/devices $ sudo <quartus_directory>/bin/jtagd $ sudo <quartus_directory>/bin/jtagconfig
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
113 Views

Try "source ~/.bashrc". If it didn't work, log out and log in, or just reboot your machine. The path to libraries is loaded from the "LD_LIBRARY_PATH" environmental variable and the way you have set it should work.

Altera_Forum
Honored Contributor II
113 Views

Hi HRZ 

"source ~/.bashrc" and rebooting didn't work. 

Ultimate solution: create a path same as the one it's trying to load from and fake a10_ref_mmd as c5gt_mmd and it works...:cool: 

Maybe I didn't uninstall quartus 17.0 clean (installation guide said just delete the folder)
Reply