Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16214 Discussions

box pups up : specify the simulation tool executable location

  • Hi,
  • I downloaded and installed: Quartus Prime Pro,
    I am ussing the Cyclone 10GX (so can complile free)
    I trying to use simulation : Tools/Launch simulation library compiler
    I fill in executable location (map) C:/intelFPGA_pro/22.2/questa_fse/win64
    then at pressing start : a box pups up : specify the simulation tool executable location. at this point i am stuck..

    Best regards,

0 Kudos
9 Replies


You should get something similar like this if setup correctly.

Do you see the same thing?

You should not see any red line warning message as well.

Which Quartus Pro version you are using?


0 Kudos


Thanks Richard.

I fill in :


==> i Do have a red line:   Specify the simulation tool executable location. *e.g. @QUESTASIM_INSTALLDIR/win64/vsim.exe)


The quartus prime version is:      22.2.0 Build 94 06/08/2022 SC Pro Edition


Looking forward to your response..


Best Regards,

Theo Mulder


0 Kudos

Can you check if the Questasim vsim.exe is installed/found at that directory path?

If the issue persists, I suggest to reinstall the Questasim.

0 Kudos

I have yet to receive any response from you in regards to my last reply.

With that, I will now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.

Best Regards,

Richard Tan

p/s: If any answer from the community or Intel support are helpful, please feel free to give Kudos and select the best solution. 

0 Kudos


This question resembles my problem exactly.  Since there never was a satisfactory answer and I am pretty frustrated, I'll try to reopen this thread in hopes of getting a solution. 


QuestaSim Starter Edition starts in stand-alone mode fine, so is not a licensing issue.


The path is 100% verified as I have went directly to the shortcut file location that launched the stand-alone QuestaSim.


But when attempting Tools -> Launch Simulation Library Compiler


I have tried with and without vsim.exe.  I have tried '\' and '/'.  The file executable is absolutely present.  So there is probably something else wrong and this is a misleading error message.  But I don't know what to do next.  My license is verified.  I wouldn't think I would have to do re-install when the stand-alone functions fine.  What does anyone think I should try next?





0 Kudos

I have exactly the same problem. Have you found a solution?

Thank you.

0 Kudos

Hello Axel-K,

Yes.  I beat my head on the wall for a day or so and then went back to reinstall as a last resort and that is where I found the solution.

During the installation, I didn't think I needed the 'full' or 'paid' version?  I just installed the FSE version.  When I went back to the installer, I had the long shot idea of installing both, so there are now questa_fe and questa_fse directories as shown.


Then simply select the questa_fse directory as shown below:


and.... success...



I wish you luck!!









0 Kudos

Hello Mil,


Thanks a lot for your feedback. 

I tried it, but it is still not working. There is a strange difference in the error messages.

Your error message:


My error message:



Asking you for the 64bit version, but asking me for the 32bit version. But I'm not aware that I could select it during installation. I have a new computer, so I'm sure that 64bit should be no problem.


I love your original solution, do you have a second one handy?

0 Kudos

Hello Axel,

Well......  We're in for a bumpy ride.  I don't think windows being 32-bit is the problem?  You can have a brand new pc that is 64-bit.  If you install 32-bit Windows on it, it will be 32 bits.  You can check that by looking at system properties on my computer.  I am going to ignore that, because it shouldn't act any differently.  What I DID notice, you were using the newest Quartus 23.2 while I was using ancient Quartus 23.1.  In interest of upgrading my version to the latest on company time, I uninstalled 23.1 and started everything over again with 23.2.


What I am trying to do is evaluate the PCIe demo that runs on the evaluation board.  And there is pain in downloading, upgrading libraries, needing Arria files even though it is for Cyclone.  But I'm going to skip all that explanation and where I am at is I can compile, synthesize, and PAR this demo.  Now, I want to build the simulation libraries.


Step 1:  If you can't run the standalone Questa FSE, then you will never get it to run.  So, need to make sure you have the license file for this.  Because of the different version, I had to generate a new one.  The e-mail from Intel will say something like this.

Product Details:

 Products               :       Questa*-Intel® FPGA Starter Edition SW-QUESTA, Intel® Quartus®
                               Prime Software SW-ONE-QUARTUS                                                       Primary Machine        :       Alienware                


Step 2:  Next, you need to create a system variable called LM_LICENSE_FILE that points to wherever you put that license file.


Step 3:  After this, you should be able to run Questa from the Start Menu (this IS vsim.exe).


If you can't get past here, stop and try and make this work first.

Step 4:  Tools -> Generate Simulator Script for IP  (I had to stop here and run Platform Designer to generate spd files, you may not need to).

Step 5:  Have a priest bless your PC.  Sacrifice a virgin if you have one handy.  What I found to work here makes only the slightest bit of sense.  But I have repeated it over and over again.  I select the fse directory.  (for you replace win64 with win32.....)


Hit select folder.


Delete the 's'.  And Start Compilation.


First time - 6 warnings.  Note if you do Start Compilation again, it will fail.  Repeat process from select folder (deleting the 's' like a crazy person).


Second time - 7 warnings.  The warning is due to overwriting a protected file that I generated from the first run.  There is no third time.  No matter what I do, I can't make it work again until I delete the contents of the output directory.  Can run twice and then have to clean.



I am by no means an Altera expert.  Haven't used it in 20 years and decided I would give it another try.  Everything I am doing here is trial and mostly error.  But I have tried to give you something that would work for you.  As to why this MIGHT work .......

Here is where I delve into complete speculation.  As a software designer, I know that the contents of that textbox should have updated a variable after we selected the file.  That variable is what should be used when we press Start Compilation.  It appears as if it does not.  By editing the textbox, that appears to have updated the variable and THEN we can run Start Compilation.  I tested using select folder to FE directory and added a '/' at the end and it worked ... though it wasn't as repeatable as what I documented above.  I also have made it compile using selecting FSE folder and adding the '/'.  (Whole different VSIM!!!!)



(I highlighted Starter.)

Whatever the case in my speculation may be, I can guarantee the error message is a catch all for any problem it encounters.  I received it when the license file wasn't right, for example.  I hope this works for you!  Good luck!!!













0 Kudos