Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.

build issue with EDS

Altera_Forum
Honored Contributor II
1,991 Views

hi all, 

I built hello_world through make -f Makefile command, but it showed"arm-linux-gnueabinf-g++: error : /libpath:C:/altera/14.1/hld/host/windows64/lib/: Invalid argument", "arm-linux-gnueabinf-g++: error :alteracl.lib: no such file or directory" ...... 

It seems the path C:/altera/14.1/hld/host/windows64/lib/ is invalid on windows. this path seems to be modified to /cygdrive/c/altera/14.1/hld/host/windows64/lib/ ? and which file should I modify? or solve it in another way. 

 

 

Thanks
0 Kudos
8 Replies
Altera_Forum
Honored Contributor II
857 Views

If I must build host application on linux ?

0 Kudos
Altera_Forum
Honored Contributor II
857 Views

I got this to compile on my windows 7 machine by making a small change to the makefile. 

 

replace: 

AOCL_LINK_CONFIG := $(shell aocl link-config) 

 

with: 

AOCL_LINK_CONFIG := $(shell aocl link-config --arm)
0 Kudos
Altera_Forum
Honored Contributor II
857 Views

Thanks to your answer, I will try.

0 Kudos
Altera_Forum
Honored Contributor II
857 Views

Hi, 

 

To let you know I had exactly the same issue, and the proposed workaround resolved the issue.
0 Kudos
Altera_Forum
Honored Contributor II
857 Views

I is beginner in this OpenCL theme and in yesterday has download the last version of HelloWorld, install last version of Quartus Std 17.1 & SDK for OpenCL with ARM DS-5, my board is c5soc, OS Win7 Prof. 

And I see the same problem with "--arm" key in downloaded Makefile as is recommended from craueralt ! 

Where are trouble ? My output errors is: 

/libpath:D:/intelFPGA/17.1/hld/host/windows64/lib: Invalid argument OpenCL.lib: No such file or directory 

The command "aocl linkflags" says: 

/libpath:D:/intelFPGA/17.1/hld/host/windows64/lib OpenCL.lib 

In D:/intelFPGA/17.1/hld/host/windows64/lib I see the normal file OpenCL.lib. 

How repair this bug ?
0 Kudos
Altera_Forum
Honored Contributor II
857 Views

A problem is in "invisible" key "--arm" for command in Makefile after "shell aocl link-config", which must return a list of ARM linker parameters instead x64. 

If manually edit Makefile, clear AOCL_LINK_CONFIG, set to LIB_DIRS list of library directories and add to LIBS all need libs, then examples is compiled and runned after successful.
0 Kudos
Altera_Forum
Honored Contributor II
857 Views

 

--- Quote Start ---  

I is beginner in this OpenCL theme and in yesterday has download the last version of HelloWorld, install last version of Quartus Std 17.1 & SDK for OpenCL with ARM DS-5, my board is c5soc, OS Win7 Prof. 

And I see the same problem with "--arm" key in downloaded Makefile as is recommended from craueralt ! 

Where are trouble ? My output errors is: 

/libpath:D:/intelFPGA/17.1/hld/host/windows64/lib: Invalid argument OpenCL.lib: No such file or directory 

The command "aocl linkflags" says: 

/libpath:D:/intelFPGA/17.1/hld/host/windows64/lib OpenCL.lib 

In D:/intelFPGA/17.1/hld/host/windows64/lib I see the normal file OpenCL.lib. 

How repair this bug ? 

--- Quote End ---  

 

 

hi!  

I have the same problem,have you solved it? 

I want to change the output of "aocl link-config",how can I implement this? 

By the way,do you know the output of "aocl link-config" depends on which variable's value ???
0 Kudos
ygao15
Beginner
857 Views

I have the same problem as you,do you solved it? I am looking forward to your help.​

0 Kudos
Reply