Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16689 Discussions

jtagserver authentication failure

Honored Contributor II

Hi All, 


I have the Altera jtag server running as a service on windows 7 under user system, and I type the following commands to get remote access working. This has worked before, but I am almost ready to give on it now and physically move my chassis to another location. 


On the jtag server host XXXX I type. 


$ jtagconfig --enableremote somepassword 


$ jtagserver.exe --status 

Installed JTAG server is 'C:\altera\15.1\quartus\bin64\jtagserver.exe' 

Server is running 

Remote clients are disabled 


I have tried restarting the windows service, and I also see the password datum updating in the windows registry when I change it ... 


I had trouble getting the remote 13.1 jtag to work so I tried also upgrading the windows installation to 15.1. 


On a Linux Red Hat 6 jtag client system, where we are still running altera 13.1, I type. 


$ jtagconfig --addserver XXXX somepassword 

$ jtagconfig 

1) Remote server dugong: Authentication failure 


Does the service on windows need to run in an account other than system, or possibly there is something else I am missing? 


I doubt that this is a firewall issue as I can telnet to the Altera port on the windows and I see a connection with activity; many years ago I punched the proper holes in the windows firewall. 


Thanks for any hints, 


0 Kudos
1 Reply
Honored Contributor II

I believe I am currently experiencing the same issue with Quartus Prime Lite 17.0 on both windows 7 and Ubuntu 16.04. Did you ever get this resolved?

0 Kudos