Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
266 Discussions

Quartus in Docker 18.0 standart uboot qeneration does not work

Wild
Beginner
286 Views

I try to get quartus run inside docker. I've got everything working but:

  • Uboot generation
  • HDL generation fails at altera_pll (Platform designer)

If i ran the uboot generation according to: https://rocketboards.org/foswiki/Documentation/PreloaderUbootCustomization131

The generation exited without any error but when i try to boot it runs until:

"Hit any key to stop autoboot:"

after that it exits the boot proccess with "Unknown command 'run' ".

We have the quartus environment installed on a Oracle VM where u-boot.img can be generatet bootable. When i generate uboot on docker uboot has size 232.16 kB on VM  232.68 kB .

 

Does anyone have an idea what could be the cause oft this? 

 

My System ubuntu-trusty in docker (wsl 2, windows host): 

i run Quartus 18.0 standart with socEDS (18.0 build 614).

my dockerfile in in the attachment. 

0 Kudos
1 Reply
Isaac_V_Intel
Employee
235 Views

Hello,


The version that you are using is 13.1, we did not support that version anymore, could you please refer to the next link, this is the updated version and follow all the steps please.


https://rocketboards.org/foswiki/Documentation/BuildingBootloader


Best regards,

Isaac Vazquez.


Reply