Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
331 Discussions

Windows 10 1909 and EDS 18.1 compatibilty

Tim_Scott
Novice
708 Views

Getting this message at top line when starting Soc EDS 18.1 Command Shell:  "GetTempFileName failed with error 5".

When the BSP Editor is launched from the shell, the editor application displays these errors:

SEVERE: Error initializing BSP Components. Ensure the QUARTUS_ROOTDIR environment variable is set properly: "Failed to initialize device database."

SEVERE: Error initializing BSP Components. Ensure the QUARTUS_ROOTDIR environment variable is set properly: "Librarian is 'null'"

Environment variable settings on my machine match those of coworkers.

Using Windows 10 Enterprise 1909.  Co-workers using Windows 10 Enterprise 1809 do not experience these errors.

Are there compatibility issues with EDS 18.1 and Windows 10 1909?  If so, are there fixes for this issue?

 

 

 

0 Kudos
1 Solution
Tim_Scott
Novice
636 Views

The fix was to reimage the machine with the same Windows 10 version 1909.  Previously, only updates had been applied to bring the machine to Windows 10 v1909.

View solution in original post

5 Replies
Tim_Scott
Novice
637 Views

The fix was to reimage the machine with the same Windows 10 version 1909.  Previously, only updates had been applied to bring the machine to Windows 10 v1909.

ZLutz
Beginner
349 Views

 

As far as launching bsp-editor is concerned, you can run the Embedded_Command_Shell script (it will still fail with "error 5"). Once you see the Cygwin terminal prompt, and before attempting to launch bsp-editor, you will need to overwrite the path set for QUARTUS_ROOTDIR. As you can see in the picture below, the issue with the value of QUARTUS_ROOTDIR is that the path is as defined for Windows but ought to be defined with respect to the Cygwin shell, i.e. change the beginning of the path from "C:/" to "/cygdrive/c/". In other words, type the following command in the cygwin shell (provided that you took the default installation path for Quartus 18.1 in Windows). 

 export QUARTUS_ROOTDIR="/cygdrive/c/intelFPGA/18.1/quartus" 

Now you should be able to launch bsp-editor without errors. To be clear, I understand that this (a) already has a solution, and (b) not a solution to your problem of the GetTempFileName error, but rather a workaround that enables you to continue to use the BSP editor. The point is to provide a workaround for anyone else who is put off by re-imaging their PC in order to use the development tools they need.   

 

ZLutz_0-1644528363045.png

 

ZLutz
Beginner
335 Views

BTW: if you're looking for a more permanent solution, you can edit the shell script 'env.sh' which can be found under the 'embedded' directory that is level with your quartus root. Change the -m flag to -u in the call to 'cygpath' which will give a unix path instead of a mixed path:

 

export QUARTUS_ROOTDIR="$(cygpath -m "${_QUARTUS_ROOTDIR}" 2>/dev/null)"

export QUARTUS_ROOTDIR="$(cygpath -u "${_QUARTUS_ROOTDIR}" 2>/dev/null)"

 

 

snippet of env.sh below for reference

ZLutz_1-1644542638052.png

 

 

Tim_Scott
Novice
326 Views

Great info - thank you for posting.

Tim_Scott
Novice
342 Views

Good info - Thank you for taking the time to post this alternate solution.

Reply