Intel® Software Guard Extensions (Intel® SGX)
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

can't find enclave template in visual studio 2017

TrueAbc
New Contributor I
391 Views

I have installed SGX SDK 2.11.100.3 on my windows 10. 

1.png

2.png

 

But I can't find enclave template in my visual studio 2017 pro  and can't build or execute SamplteEnclave Project in  "C:\Program Files (x86)\Intel\IntelSGXSDK\src\SampleEnclave".

3.png

4.png

Visual Studio told me it could't find sgx_capable.h  which i can find in  "C:\Program Files (x86)\Intel\IntelSGXSDK\include". 

TrueAbc_1-1607670285572.png

Do I  need to configure SGX  SDK  PATH manually or do something else to fix the problem?

Thanks a lot. 

 

 

  

 

0 Kudos
1 Solution
JesusG_Intel
Moderator
291 Views

Hello Trueabc,

A new version of the SGX SDK for Windows with a fix for Visual Studio integration will be released at the end of January.

Sincerely,
Jesus G.
Intel Customer Support

View solution in original post

4 Replies
TrueAbc
New Contributor I
378 Views

TrueAbc_0-1607694442194.png

 

After installing all of this addtionally, I could run SampleEnclave in Simulation mode.

TrueAbc_1-1607694856340.png

 

However,  release mode still don't work. It told me that "sgx_urts.dll"  couldn't be found. And I still can't find enclave template in visual studio.

TrueAbc_0-1607694829364.png

I have checked BIOS setting and enabled SGX.  

But still not know how to fix the problem.

Could anyone give me some advice?

 

newsgxer
Beginner
340 Views

have you solved the problem?i am also faced with this situation

TrueAbc
New Contributor I
326 Views

No, I have stopped trying.   I can run SampleProject in visual studio without enclave template . That't enough for my study.

JesusG_Intel
Moderator
292 Views

Hello Trueabc,

A new version of the SGX SDK for Windows with a fix for Visual Studio integration will be released at the end of January.

Sincerely,
Jesus G.
Intel Customer Support

View solution in original post

Reply