Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.
6539 Discussions

FFT, DftiCommitDescriptor error: Module not found

Serjio
New Contributor I
555 Views

tried to use FFT from MKL and got an error.

I'm using Win10, VS2019 and mkl 2021.2.0 from intel.oneapi.win.BaseKit.package.

 

I run official one-dimensional In-place FFT example ( see basic_dp_complex_dft_1d.c ) in c++ console application and defined an error.

 

status = DftiCommitDescriptor(hand); // Error is here

 Here it is an error message - "Exception adress 0x76C2A6E2 (KernelBase.dll) in test.exe: 0xC06D007E: Module not found ".

 

Could please help me to fix this problem?

 

0 Kudos
1 Solution
MRajesh_intel
Moderator
475 Views

Hi,

 

When you set debug to x86 mode, automatically 32-bit implementation of the compiler is added to the environment.

 

If not done automatically set the path to:

 

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\ia32_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\ia32;%PATH%

 

 

 

I hope this answers your query. Please let us know if you have any other issues. If not, can we proceed further to close this thread?

 

Regards

Rajesh.

 

View solution in original post

6 Replies
MRajesh_intel
Moderator
514 Views

Hi,

 

Can you please share the Visual Studio version and the settings used? In the meanwhile, try setting the environment details in Debugging section, in the Configuration Properties section to:

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\intel64_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\intel64;%PATH%

 

 

Let us know if you face any issues.

 

Regards

Rajesh.

 

Serjio
New Contributor I
509 Views

Hi, Rajesh.

 

My Visual Studio version: Community 2019 v16.9.4

 

It seems to me, that my project needs to be configured correctly.

When I specify the environment details in Debugging section, in the Configuration Properties section to:

 

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\intel64_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\intel64;%PATH%

 

debugging.jpg

I get an error when debugging starts:
"Error while starting the application (0xc000007b)"

So, please help me set up Visual Studio to use Intel OneMKL.

Let's start by setting the environment variables as I haven't set any variables since installing Intel oneAPI.win.BaseKit.
This is how my Visual Studio settings look like:

VS2019_settings1.jpg

VS2019_settings2.jpg

VS2019_settings3.jpg

 

VS2019_settings4.jpg

VS2019_settings5.jpg

VS2019_settings6.jpg

VS2019_settings7.jpg

Do I need to use the setvars.bat script from Intel oneAPI to set system variables in Windows?

Sorry there are so many questions))

MRajesh_intel
Moderator
502 Views

Hi,

 

Also, try setting the Debug setting to x64 and let us know if that works.

 

Debug Setting.PNG

Regards

Rajesh.

 

Serjio
New Contributor I
495 Views

If I set "Solution Platforms" to x64, then the FTF calculation works fine!

VisualStudio2019_Ok.jpg


Thanks, Rajesh.
But... if I need to do my project in x32 mode? How to make debug in x32 mode?

MRajesh_intel
Moderator
476 Views

Hi,

 

When you set debug to x86 mode, automatically 32-bit implementation of the compiler is added to the environment.

 

If not done automatically set the path to:

 

PATH=C:\Program Files (x86)\Intel\oneAPI\compiler\2021.2.0\windows\redist\ia32_win\compiler;C:\Program Files (x86)\Intel\oneAPI\mkl\2021.2.0\redist\ia32;%PATH%

 

 

 

I hope this answers your query. Please let us know if you have any other issues. If not, can we proceed further to close this thread?

 

Regards

Rajesh.

 

MRajesh_intel
Moderator
465 Views

 Hi,

 

Thanks for accepting as a Solution.

 

As this issue has been resolved, we will no longer respond to this thread. If you require any additional assistance from Intel, please start a new thread. Any further interaction in this thread will be considered community only.

 

Have a Good day.

 

Regards

Rajesh

 

Reply