Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.

libiomp5md.dll not found - VS2015 update 3


I have a fresh install of VS2015 Update 3, and MKL 2017.2.187.  It is a stand alone MKL license, I don't have the wider Intel compiler tools.

When I run my project, I get an error of a missing libiomp5md.dll.  Using process monitor, I can see that C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.2.187\windows\redist\ia32_win\mkl has been added to the PATH environment variable, but the missing dll is in a compiler sub-folder that isn't in the path.  The same problem with a 64-bit build as well.

This is a regression from MKL version 2017.0.109, which I was previously using.

I have worked around it by copying all the redist files into the mkl folder that is added to the path.  Is there a MSBuild file that should be fixed instead?

It seems similar to, something isn't setting up the PATH, and I guess it is because I don't have the Intel compiler installed.  Is this something that isn't covered in your testing?

0 Kudos
2 Replies

Hi Alan,

The lib for Intel OMP should be installed even you intsall IPP/MKL stand alone, it is always saved in compiler sub-folder, not MKL folder. If you are going to use dynamic linking, please check with your environmental variable if this path has been added into Path, C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.2.187\windows\redist\intel64\compiler;

Best regards,

0 Kudos

Hi Fiona

No, I don't have any Intel folders in Path.

I see that the other PC has INTEL_DEV_REDIST=C:\Program Files (x86)\Common Files\Intel\Shared Libraries\

and Path includes:
which are not created with 2017.2.187, and are presumably a result of two separate installs as the later two don't exist.

So both installs are adding the mkl redist path to VCRedistPaths which gets added to PATH when I launch the project from Visual Studio, and neither is adding the compiler redist path.  Instead the older install has the compiler added to the global PATH, and 2017.2.187 is not adding it.


0 Kudos